《算法笔记》7.1小节——数据结构专题(1)->栈+队列->问题 A: 简单计算器

版权声明:关中大侠Lv轻侯 https://blog.csdn.net/weixin_44312186/article/details/88717378

题目描述

读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。

输入

测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。

输出

对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。

样例输入

30 / 90 - 26 + 97 - 5 - 6 - 13 / 88 * 6 + 51 / 29 + 79 * 87 + 57 * 92
0

样例输出

12178.21 

代码:

#include<iostream>
#include<cstdio>
#include<string>
#include<stack>
#include<queue>
#include<map>
using namespace std;

struct node
{
	double num;//操作数
	char op;//操作符
	bool flag;//true表示操作数,false表示操作符
};
string str;
stack<node> s;
queue<node> q;
map<char,int> op;

void change()
{
	double num;
	node temp;
	for(int i=0; i<str.length();)
	{
		if(str[i]>='0'&&str[i]<='9') //如果是数字
		{
			temp.flag=true;          //标记为数字
			temp.num=str[i++]-'0';   //读当前位的数字
			while(i<str.length()&&str[i]>='0'&&str[i]<='9') //当数字位数大于一时 ,更新
			{
				temp.num=temp.num*10+(str[i]-'0');
				i++;
			}
			q.push(temp);//数字入队列
		}
		else //如果是字母
		{
			temp.flag=false;//标记为操作符
			while(!s.empty()&&op[str[i]]<=op[s.top().op]) //当栈非空且当前操作符的优先级小于栈顶元素时出栈,并将其加入到后缀队列中
			{
				q.push(s.top());
				s.pop();
			}
			temp.op=str[i];
			s.push(temp);//操作符入栈
			i++;
		}
	}
	while(!s.empty())//当前栈中还有剩余操作符时,出栈,入队列
	{
		q.push(s.top());
		s.pop();
	}
}

double cal() //计算后缀表达式,,,,,返回类型为double!!!(否则有可能出不来结果)
{
	double temp1,temp2;
	node cur,temp;
	while(!q.empty())
	{
		cur=q.front();
		q.pop();
		if(cur.flag==true)   //如果当前位为数字则入栈
		{
			s.push(cur);
		}
		else  //如果当前位是操作符,则取操作数
		{
			temp2=s.top().num;
			s.pop();
			temp1=s.top().num;
			s.pop();
			temp.flag=true;
			if(cur.op=='+') temp.num=temp1+temp2;
			else if(cur.op=='-') temp.num=temp1-temp2;
			else if(cur.op=='*') temp.num=temp1*temp2;
			else  temp.num=temp1/temp2;
			s.push(temp);//将操作结果入栈
		}
	}
	return s.top().num;//栈顶元素就是后缀表达式的值
}

int main()
{
	op['+']=1;
	op['-']=1;//优先级低
	op['*']=2;
	op['/']=2;//优先级高
	while(getline(cin, str),str != "0")
	{
		for(string::iterator it=str.end(); it!=str.begin(); it--)
		{
			if(*it==' ') str.erase(it);//删除表达式中的空格
		}
		while(!s.empty())
		{
			s.pop();//初始化栈
		}
		change();//变为后缀表达式
		printf("%.2f\n",cal());//输出计算结果
	}
	return 0;
}

 ps:主要是对栈和队列的运用

分两步:1、中缀表达式转化为后缀表达式。    2、后缀表达式的计算。

猜你喜欢

转载自blog.csdn.net/weixin_44312186/article/details/88717378