pta-树种统计

树种统计 (25 分)

随着卫星成像技术的应用,自然资源研究机构可以识别每一棵树的种类。请编写程序帮助研究人员统计每种树的数量,计算每种树占总数的百分比。

输入格式:

输入首先给出正整数N(105​​),随后N行,每行给出卫星观测到的一棵树的种类名称。种类名称由不超过30个英文字母和空格组成(大小写不区分)。

输出格式:

按字典序递增输出各种树的种类名称及其所占总数的百分比,其间以空格分隔,保留小数点后4位。

输入样例:

29
Red Alder
Ash
Aspen
Basswood
Ash
Beech
Yellow Birch
Ash
Cherry
Cottonwood
Ash
Cypress
Red Elm
Gum
Hackberry
White Oak
Hickory
Pecan
Hard Maple
White Oak
Soft Maple
Red Oak
Red Oak
White Oak
Poplan
Sassafras
Sycamore
Black Walnut
Willow

输出样例:

Ash 13.7931%
Aspen 3.4483%
Basswood 3.4483%
Beech 3.4483%
Black Walnut 3.4483%
Cherry 3.4483%
Cottonwood 3.4483%
Cypress 3.4483%
Gum 3.4483%
Hackberry 3.4483%
Hard Maple 3.4483%
Hickory 3.4483%
Pecan 3.4483%
Poplan 3.4483%
Red Alder 3.4483%
Red Elm 3.4483%
Red Oak 6.8966%
Sassafras 3.4483%
Soft Maple 3.4483%
Sycamore 3.4483%
White Oak 10.3448%
Willow 3.4483%
Yellow Birch 3.4483%

#include<iostream>
#include<iomanip>
#include<map>
using namespace std;
int main()
{
    map<string,int>tree;
    map<string,int>::iterator iter;
    int n;
    string s;
    cin>>n;
    int sum=0;
    getchar();     // 注意getline前读取回车!
    while(n--)
    {
        getline(cin,s);
        if(tree.find(s)!=tree.end())
        tree[s]++;
        else
        tree[s]=1;
        sum++;
    }
    int flag=0;
    for(iter=tree.begin();iter!=tree.end();iter++)
    {
        if(flag==1) cout<<endl;
        cout<<iter->first<<" "<<fixed<<setprecision(4)<<iter->second/(float)sum*100<<"%";
        flag = 1;
    }
 } 

精度设置:

  1. 直接setprecision设置有效数字的位数
  2. fixed再setprecision设置小数点后位数
  3. 注意include<iomanip>

map反向遍历:

    for(iter=--tree.end();iter!=--tree.begin();iter--)
    {
        if(flag==1) cout<<endl;
        cout<<iter->first<<" "<<fixed<<setprecision(4)<<iter->second/(float)sum*100<<"%";
        flag = 1;
    }

猜你喜欢

转载自www.cnblogs.com/miliye/p/10542071.html