反转问题POJ_3279

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/sumword_/article/details/66619446
Fliptile
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 9453   Accepted: 3532

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes the colors (left to right) of row i of the grid with  N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains  N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

题意:有一个矩阵,里面有元素0或1,目标矩阵全为0,每次选择一个元素,并反转这个元素和它周围的四个元素,问最少需要反转几次?打印出反转元素的矩阵。

思路:遍历第一排元素。则下面一排的元素都随之确定(下面一排的元素是否反转取决于上一排是否是1),然后往下遍历,遍历完最后一排,看最后一排是否都是0.遍历第一排的时候可以用位运算的技巧。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#define INF 0x3f3f3f3
#define MAXN 150
using namespace std;
int a[MAXN][MAXN];
int b[MAXN][MAXN];
int n,m;
int jilu[MAXN][MAXN];
int jilu2[MAXN][MAXN];
int minstep;
int solve(int k){
    memset(jilu,0,sizeof(jilu));
    int step = 0;
    for(int i = 1; i <= n; i++)
        for(int j = 1; j <= m; j++)
            b[i][j] = a[i][j];
    for(int i = 1; i <= m; i++){
        int temp = k&1;
        k = k >> 1;
        if(temp){
            b[1][i-1] = 1^b[1][i-1];
            b[1][i] = 1^b[1][i];
            b[1][i+1] = 1^b[1][i+1];
            b[2][i] = b[2][i]^1;
            jilu[1][i] = 1;
            step++;
        }
    }
    for(int i = 2;  i <= n; i++){
        for(int j = 1; j <= m; j++){
            if(b[i-1][j] == 1){
                jilu[i][j] = 1;
                b[i][j] ^= 1;
                b[i-1][j] ^= 1;
                b[i+1][j] ^= 1;
                b[i][j-1] ^= 1;
                b[i][j+1] ^= 1;
                step++;
            }
        }
    }
    for(int i = 1; i <= m; i++)
        if(b[n][i] == 1)
            return -1;
    if(step < minstep){
        minstep = step;
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= m; j++)
                jilu2[i][j] = jilu[i][j];
    }
}
int main(){
    while(scanf("%d%d",&n,&m) == 2){
        minstep = MAXN*MAXN+1;
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= m; j++)
                scanf("%d",&a[i][j]);
        for(int i = 0; i <= (1<<(m+1))-1; i++)
            solve(i);
        if(minstep == MAXN*MAXN+1)
            cout << "IMPOSSIBLE" << endl;
        else
            for(int i = 1; i <= n; i++){
                printf("%d",jilu2[i][1]);
                for(int j = 2; j <= m; j++)
                    printf(" %d",jilu2[i][j]);
                printf("\n");
            }
    }
}


猜你喜欢

转载自blog.csdn.net/sumword_/article/details/66619446
今日推荐