【POJ - 3974】Palindrome (马拉车算法)

版权声明:如果有什么问题,欢迎大家指出,希望能和大家一起讨论、共同进步。 https://blog.csdn.net/QQ_774682/article/details/88285177

Andy the smart computer science student was attending an algorithms class when the professor asked the students a simple question, "Can you propose an efficient algorithm to find the length of the largest palindrome in a string?" 

A string is said to be a palindrome if it reads the same both forwards and backwards, for example "madam" is a palindrome while "acm" is not. 

The students recognized that this is a classical problem but couldn't come up with a solution better than iterating over all substrings and checking whether they are palindrome or not, obviously this algorithm is not efficient at all, after a while Andy raised his hand and said "Okay, I've a better algorithm" and before he starts to explain his idea he stopped for a moment and then said "Well, I've an even better algorithm!". 

If you think you know Andy's final solution then prove it! Given a string of at most 1000000 characters find and print the length of the largest palindrome inside this string.

Input

Your program will be tested on at most 30 test cases, each test case is given as a string of at most 1000000 lowercase characters on a line by itself. The input is terminated by a line that starts with the string "END" (quotes for clarity). 

Output

For each test case in the input print the test case number and the length of the largest palindrome. 

Sample Input

abcbabcbabcba
abacacbaaaab
END

Sample Output

Case 1: 13
Case 2: 6

思路:

马拉车算法模板题,马拉车算法需要注意记录半径的p数组需要开至少字符串两倍的空间。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<string>
#include<vector>
using namespace std;
typedef long long ll;
int p[2000020];//p数组需要开至少字符串两倍的空间 
int Manacher(char str[])
{
	memset(p,0,sizeof(p));
	string s="$#";
	int len=strlen(str);
	for(int i=0;i<len;i++)
	{
		s+=str[i];
		s+='#';
	}
	int mx=0,id=0,reslen=0,rescenter=0;
	len=s.length();
	for(int i=1;i<=len;i++)
	{
		p[i]=mx>i?min(p[2*id-i],mx-i):1;//
		while(s[i+p[i]]==s[i-p[i]])p[i]++;
		if(mx<i+p[i])
		{
			mx=i+p[i];
			id=i;
		}
		if(reslen<p[i])
		{
			reslen=p[i];
			rescenter=i;
		}
	}
	return reslen-1;
}
char s[1010100];
int main()
{
	int t=1;
	while(~scanf("%s",s))
    {
    	if(strcmp(s,"END")==0)
    	break;
    	printf("Case %d: %d\n",t++,Manacher(s));
	}
	return 0; 
}

猜你喜欢

转载自blog.csdn.net/QQ_774682/article/details/88285177