UVA - 424【高精度运算】

UVA - 424

One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration of
powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
“This supercomputer is great,” remarked Chip. “I only wish Timothy were here to see these results.”
(Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky
apartments on Third Street.)
Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger.
Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no
VeryLongInteger will be negative).
The final input line will contain a single zero on a line by itself.
Output
Your program should output the sum of the VeryLongIntegers given in the input.
Sample Input
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0
Sample Output
370370367037037036703703703670

链接:https://vjudge.net/problem/19484/origin

简述:将多个远远超于整数最大值的整数相加输出结果

分析:用字符串来做,输入字符串,转化为数字计算。

说明:(高精度运算)

正在UVA排队的代码如下:

#include <iostream>
#include <cmath>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
using namespace std;
int na[105]; int nb[105];
string add(string a, string b)
{
	na[105] = { 0 }; nb[105] = { 0 };
	int la, lb, i;
	la = a.size(); lb = b.size(); //a.size(),忘记打括号
	for (i = 0; i < la; i++)
	{
		na[la - 1 - i] = a[i] - '0';//记得减i
	}
	for (i = 0; i < lb; i++)
	{
		nb[lb - 1 - i] = b[i] - '0';
	}
	int lmax;
	lmax = la > lb ? la : lb;
	for (i = 0; i < lmax; i++)
	{
		na[i] += nb[i];
		na[i + 1] += na[i] / 10;
		na[i] = na[i] % 10;
	}
	string sum;
	if (na[lmax]) lmax++; //如果最高位进了一位
	for (i = lmax - 1; i >= 0; i--)
	{
		sum += na[i] + '0';
	}
	return sum;
}
int main()
{
	string a, b;
	string sum;
	cin >> a >> b;
	sum = add(a, b);
	while (cin >> a && a[0] != '0')
	{
		sum = add(sum, a);
	}
	cout << sum << endl;
}

猜你喜欢

转载自blog.csdn.net/qq_43966202/article/details/86688625