hdu--Lost Cows

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.

Given this data, tell FJ the exact ordering of the cows.

Input

* Line 1: A single integer, N

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3

1

题意:给你n头牛,再给你每头牛前面的牛的数量,然后给牛排序,倒序排序,用线段树区间和来计算每头牛前面有多少头牛

<span style="font-size:18px;">#include<stdio.h>
#include<string.h>
#include<algorithm>
const int MAXN=8005;
using namespace std;
int a[MAXN],b[MAXN];
struct node
{
    int l,r,sum;
}tr[MAXN*4];
void build(int id,int l,int r)
{
    tr[id].l=l;
    tr[id].r=r;
    tr[id].sum=r-l+1;//注意这里
    if(l==r)
        return ;
    int mid=(l+r)>>1;
    build(id<<1,l,mid);
    build((id<<1)+1,mid+1,r);
}
int query(int id,int val)
{
    tr[id].sum--;//遍历到了就让牛总数减1
    if(tr[id].l==tr[id].r)
        return tr[id].l;//这里不能写成tr【id】。sum,因为sum在--;
    if(val<=tr[id<<1].sum)
        return query(id<<1,val);//如果左边区间牛空位足够的话,就去左区间
    else
        return query((id<<1)+1,val-tr[id<<1].sum);//反之到右区间
}
int main()
{
    int n;
    scanf("%d",&n);
    build(1,1,n);
    a[1]=0;
    for(int i=2;i<=n;i++)
        scanf("%d",&a[i]);
    for(int i=n;i>=1;i--)
    {
        b[i]=query(1,a[i]+1);
    }
    for(int i=1;i<=n;i++)
        printf("%d\n",b[i]);
    return 0;
}
</span>


猜你喜欢

转载自blog.csdn.net/Foverve1/article/details/52202964