A - Commando War

题目链接:

https://cn.vjudge.net/contest/274196#problem/A 

“Waiting for orders we held in the wood, word from the front never came By evening the sound of the gunfire was miles away Ah softly we moved through the shadows, slip away through the trees Crossing their lines in the mists in the fields on our hands and our knees And all that I ever, was able to see The fire in the air, glowing red, silhouetting the smoke on the breeze” There is a war and it doesn’t look very promising for your country. Now it’s time to act. You have a commando squad at your disposal and planning an ambush on an important enemy camp located nearby. You have N soldiers in your squad. In your master-plan, every single soldier has a unique responsibility and you don’t want any of your soldier to know the plan for other soldiers so that everyone can focus on his task only. In order to enforce this, you brief every individual soldier about his tasks separately and just before sending him to the battlefield. You know that every single soldier needs a certain amount of time to execute his job. You also know very clearly how much time you need to brief every single soldier. Being anxious to finish the total operation as soon as possible, you need to find an order of briefing your soldiers that will minimize the time necessary for all the soldiers to complete their tasks. You may assume that, no soldier has a plan that depends on the tasks of his fellows. In other words, once a soldier begins a task, he can finish it without the necessity of pausing in between. Input There will be multiple test cases in the input file. Every test case starts with an integer N (1 ≤ N ≤ 1000), denoting the number of soldiers. Each of the following N lines describe a soldier with two integers B (1 ≤ B ≤ 10000) & J (1 ≤ J ≤ 10000). B seconds are needed to brief the soldier while completing his job needs J seconds. The end of input will be denoted by a case with N = 0. This case should not be processed. Output For each test case, print a line in the format, ‘Case X: Y ’, where X is the case number & Y is the total number of seconds counted from the start of your first briefing till the completion of all jobs. Sample Input 3 2 5 3 2 2 1 3 3 3 4 4 5 5 0 Sample Output Case 1: 8 Case 2: 15 

#include <iostream>
#include <stdlib.h>
#include <stdio.h>
#include <queue>
#include<algorithm>
using namespace std;

/* run this program using the console pauser or add your own getch, system("pause") or input loop */

typedef struct soliders{
	int B;
	int J;
	friend bool operator<(soliders n1,soliders n2)
	{
		return n1.J<n2.J;
	}
}S;

int main(int argc, char** argv) {
	int N;
	long long int sum=0,ans=0,M=0,M1=0;
	scanf("%d",&N);
	while(N!=0)
	{
		S temp,temp1;
		priority_queue<S> qi;
		for(int i=0;i<N;i++)
		{
			scanf("%d%d",&temp.B,&temp.J);
			qi.push(temp);
		}
	
		for(int i=0;i<N;i++)
		{
			temp1=qi.top();
			qi.pop();
			M+=temp1.B;
			ans=max(ans,M+temp1.J);
		}
		sum++;
		printf("Case %lld: %lld\n",sum,ans);
		scanf("%d",&N);
		ans=0;
		M=0;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43442778/article/details/84844185
war