PAT(A) 1126. Eulerian Path (25)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/huqiao1206/article/details/79531167

原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1126

1126. Eulerian Path (25)


In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (<= 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph – either “Eulerian”, “Semi-Eulerian”, or “Non-Eulerian”. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:
7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6
Sample Output 1:
2 4 4 4 4 4 2
Eulerian
Sample Input 2:
6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6
Sample Output 2:
2 4 4 4 3 3
Semi-Eulerian
Sample Input 3:
5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3
Sample Output 3:
3 3 4 3 3
Non-Eulerian

题目大意

欧拉图,根据题意判断,对于一个联通图,若所有点的度都是偶数,则为”Eulerian”,若仅有两个点的度为奇数,则为”Semi-Eulerian”,否则为”Non-Eulerian”。

解题报告

首先为联通图,用dfs判断。
其次记录每个点的度数,用于后面判断。

代码

/*
* Problem: 1126. Eulerian Path (25)
* Author: HQ
* Time: 2018-03-12
* State: Done
* Memo: 图,dfs
*/
#include "iostream"
using namespace std;

int N,M;
int degree[500 + 5];
int G[500 + 5][500 + 5];
int visit[500 + 5];
int even = 0;
int cnt = 0;

void dfs(int x) {
    visit[x] = 1;
    cnt++;
    for (int i = 1; i <= N; i++) {
        if (!visit[i] && G[x][i])
            dfs(i);
    }
}

int main() {
    cin >> N >>M;
    int x, y;
    fill(degree, degree + 500 + 5, 0);
    fill(visit, visit + 500 + 5, 0);
    for (int i = 0; i < M; i++) {
        cin >> x >> y;
        G[x][y] = 1;
        G[y][x] = true;
        degree[x] ++;
        degree[y] ++;
    }
    bool first = true;
    for (int i = 1; i <= N; i++) {
        if (first) {
            cout << degree[i];
            first = false;
        }
        else
            cout << " " << degree[i];
        if (degree[i] % 2 == 0)
            even++;
    }
    cout << endl;
    dfs(1);
    if(cnt != N)
        cout << "Non-Eulerian" << endl;
    else if (even == N)
        cout << "Eulerian" << endl;
    else if(even == N-2)
        cout << "Semi-Eulerian" << endl;
    else
        cout << "Non-Eulerian" << endl;

    system("pause");
}

猜你喜欢

转载自blog.csdn.net/huqiao1206/article/details/79531167
今日推荐