L1-1 古风排

L1-1 古风排版 (20 分)

中国的古人写文字,是从右向左竖向排版的。本题就请你编写程序,把一段文字按古风排版。

输入格式:

输入在第一行给出一个正整数N(<100),是每一列的字符数。第二行给出一个长度不超过1000的非空字符串,以回车结束。

输出格式:

按古风格式排版给定的字符串,每列N个字符(除了最后一列可能不足N个)。

输入样例:

4
This is a test case

输出样例:

asa T
st ih
e tsi
 ce s

 以下代码:

#include<iostream>
#include<string>
#include<stdio.h>
#include<cstring>
#include<string>
using namespace std;
int main(){
	int n;
	cin>>n;
	getchar();
	string s;
	getline(cin,s);
	//cout<<s<<endl;
	int c=1;
	int len=s.length();
	while(c*n<len){
		c++;
	}
	//cout<<len<<endl;
	//cout<<c<<endl;
	char a[n][c];
	int t=0;
	for(int i=c-1;i>=0;i--){
		for(int j=0;j<n;j++){
			if(t<len)
				a[j][i]=s[t++];
			else
				a[j][i]=' ';
		}
	}
	for(int i=0;i<n;i++){
		for(int j=0;j<c;j++){
			cout<<a[i][j];
		}
		cout<<endl;
	}
	system("pause");
}

猜你喜欢

转载自blog.csdn.net/Helloirbd/article/details/87889600