PAT 甲级 1120 Friend Numbers

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/a845717607/article/details/87900288

1120 Friend Numbers (20 point(s))

Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different frind ID's among them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 10​4​​.

Output Specification:

For each case, print in the first line the number of different frind ID's among the given integers. Then in the second line, output the friend ID's in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:

8
123 899 51 998 27 33 36 12

Sample Output:

4
3 6 9 26

经验总结:

emmmm 简单的划水题,不多说啦~

AC代码

#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn=40;
bool flag[maxn]={false};
int n;
char str[6];
vector<int> ans;
int sum(char s[])
{
	int res=0;
	for(int i=0;s[i]!='\0';++i)
		res+=s[i]-'0';
	return res;
}
int main()
{
	scanf("%d",&n);
	for(int i=0;i<n;++i)
	{
		scanf("%s",str);
		int id=sum(str);
		if(flag[id]==false)
		{
			flag[id]=true;
			ans.push_back(id);
		}
	}
	sort(ans.begin(),ans.end());
	printf("%d\n",ans.size());
	for(int i=0;i<ans.size();++i)
		printf("%d%c",ans[i],i<ans.size()-1?' ':'\n');
	return 0;
}

猜你喜欢

转载自blog.csdn.net/a845717607/article/details/87900288