带权并查集 离散化思想 并查集路径方向

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS
#include<string.h>
#include<stdio.h>
#include<malloc.h>
#include<iostream>
#include<algorithm>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
#include <map>
using namespace std;
const int maxn=10066 ;
int f[maxn],r[maxn] ;
void init ()
{
    for (int i=0 ; i<maxn ; i++)
    {
        f[i] = i ;
        r[i] = 0 ;
    }
}
int find (int x)
{
    if (f[x]==x)
    {
        return x ;//
    }
    int root = find(f[x]) ;
    r[x] = (r[x]+r[f[x]])%2 ;
    f[x] = root ;
    return f[x] ;
}
int unions (int x,int y,int d)
{
    int a = find(x) ;
    int b = find(y) ;
    if (a==b)
    {
        if ((r[x]+r[y]+d)%2==0)
        {
            return 1 ;
        }
        else
            return 0 ;//奇数是1
    }
    else
    {
        f[a] = b ;
        r[a] = (r[x]+r[y]+d)%2 ;
        return 1 ;
    }
}
int main()
{
    char s[5] ;
    int n,m ;
    scanf("%d%d",&n,&m) ;
    init() ;
    map <int,int> hash ;
    int i,a,b,add=0,d ;
    for (i=1 ; i<=m ; i++)
    {
        scanf("%d %d %s",&a,&b,s) ;
        a-- ;//(a,b]
        if (hash.find(a)==hash.end())
            hash[a] = add++ ;//看出没出现过,离散化一下数据
        int x=hash[a] ;//就是把数据很大的把它们转化成小的并且保留原来的意义
        if (hash.find(b)==hash.end())
            hash[b] = add++ ;//
        int y=hash[b] ;
        if (s[0]=='o')//奇数的话
            d=1 ;
        else
            d=0 ;
        if (unions(x,y,d)==0)//此时出现错误
            break ;
    }
    printf("%d\n",i-1) ;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lanshan1111/article/details/87826068