FZU - 2221 RunningMan

ZB loves watching RunningMan! There's a game in RunningMan called 100 vs 100.

There are two teams, each of many people. There are 3 rounds of fighting, in each round the two teams send some people to fight. In each round, whichever team sends more people wins, and if the two teams send the same amount of people, RunningMan team wins. Each person can be sent out to only one round. The team wins 2 rounds win the whole game. Note, the arrangement of the fighter in three rounds must be decided before the whole game starts.

We know that there are N people on the RunningMan team, and that there are M people on the opposite team. Now zb wants to know whether there exists an arrangement of people for the RunningMan team so that they can always win, no matter how the opposite team arrange their people.

Input

The first line contains an integer T, meaning the number of the cases. 1 <= T <= 50.

For each test case, there's one line consists of two integers N and M. (1 <= N, M <= 10^9).

Output

For each test case, Output "Yes" if there exists an arrangement of people so that the RunningMan team can always win. "No" if there isn't such an arrangement. (Without the quotation marks.)

Sample Input
2
100 100
200 100
Sample Output
No
Yes
Hint

In the second example, the RunningMan team can arrange 60, 60, 80 people for the three rounds. No matter how the opposite team arrange their 100 people, they cannot win.

PS:做题时很早就发现了1.5倍的关系,后来发现少1个的情况也正确,之后发现m为奇数是减1.5,所以取整,最后好不容易对了。

AC:

#include<stdio.h>

int main()
{
int t,n,m,s;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);

if(n==m||n<m)
 printf("No\n");
else
{
s=int(1.5*m);
if(n-s+1>=0)
 printf("Yes\n");
else
 printf("No\n");
}
}
return 0;
 } 

猜你喜欢

转载自blog.csdn.net/wangke1998/article/details/80056805