1071 Speech Patterns (25 分)哈希表统计最多的单词

版权声明:假装这里有个版权声明…… https://blog.csdn.net/CV_Jason/article/details/86098739

题目

People often have a preference among synonyms of the same word. For example, some may prefer “the police”, while others may prefer “the cops”. Analyzing such patterns can help to narrow down a speaker’s identity, which is useful when validating, for example, whether it’s still the same person behind an online avatar.

Now given a paragraph of text sampled from someone’s speech, can you find the person’s most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: “Can a can can a can? It can!”

Sample Output:

can 5

解题思路

  题目大意: 给一个段句子,统计其中出现单词频率最高的,其中,单词可以由数字和字母组成,且大小写不敏感。
  解题思路: 使用getline作为输入,逐字符进行判断,一旦字符开始处于[0,9][a,z][A,Z]区间,开始记录,同时注意转换但小写,使用std::map进行统计,最后直接输出最大值即可,因为map自带排序功能,所以默认字典序(lexicographically)。

/*
** @Brief:No.1071 of PAT advanced level.
** @Author:Jason.Lee
** @Date:2019-01-08
** @Solution: Accepted!
*/

#include<string>
#include<iostream>
#include<map>

using namespace std;

bool isWord(char&c){
	if((c>='A'&&c<='Z')||(c>='a'&&c<='z')||(c<='9'&&c>='0')) return true;
	else return false;
} 

int main(){
	string line;
	getline(cin,line);
	map<string,int> mst;
	int index = 0;
	int length = line.length();
	while(index<length){
		if(isWord(line[index])){
			string word;
			while(isWord(line[index])&&index<length){
				if(line[index]>='A'&&line[index]<='Z') line[index]+=('a'-'A');
				word+=line[index++];
			}
			mst[word]++;
		}
		index++;
	}
	int max = 0;
	string word;
	for(auto elem:mst){
		if(elem.second>max){
			word = elem.first;
			max = elem.second;
		}
	}
	cout<<word<<" "<<max<<endl;
	return 0;
}

在这里插入图片描述

总结

  抱着试一试的心态直接提交了,想着应该会有一两个点不过,因为我没考虑边界情况,但是没想到居然一次AC了,看来这道题的测试数据集并不是很刁钻。这道题学到了几个陌生的单词倒是真的。

猜你喜欢

转载自blog.csdn.net/CV_Jason/article/details/86098739