PAT进阶之路——1112 Stucked Keyboard (20 分)

版权声明:有善始者实繁,能克终者盖寡。 https://blog.csdn.net/weixin_43987810/article/details/87637148

题目:

1112 Stucked Keyboard (20 分)

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but sis not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:

Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

Output Specification:

For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:

3
caseee1__thiiis_iiisss_a_teeeeeest

Sample Output:

ei
case1__this_isss_a_teest

题目大意:键盘某些键卡住了,按一次重复k次,要求找出可能的键,并且输出正确的字符串顺序。可能的键要求按照被发现的顺序输出。

分析:看过网上其他博主的代码,大多数都涉及到容器,其实本题不用容器反而更好做。对于本题,遍历字符串,只需要判断所有的同字符小串的长度是否是K的整数倍即可,若不是,则归入“好键”。

代码:

#include <iostream>
using namespace std;
int good[126], vis[126];//vis标记坏键是否输出过一次

int main()
{
    int i, j, k;
    int K;
    char s[1010];
    cin >> K >> s;
    for(i = 0; s[i] != '\0'; )
    {
        for(j = i; s[j] == s[i]; j++)
            ;
        if((j - i) % K) good[s[i]] = 1;
        i = j;
    }
    for(i = 0; s[i] != '\0'; i++)
        if(!good[s[i]] && !vis[s[i]])//如果是没有输出过的坏键
            cout << s[i], vis[s[i]] = 1;
    cout << endl;
    for(i = 0; s[i] != '\0'; i++)
    {
        cout << s[i];
        if(!good[s[i]]) i += K - 1;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43987810/article/details/87637148
今日推荐