#1112. Stucked Keyboard【模拟】

原题链接

Problem Description:

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k k k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k k k times whenever it is pressed. For example, when k = 3 k=3 k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:

Each input file contains one test case. For each case, the 1st line gives a positive integer k k k ( 1 < k ≤ 100 1<k\leq 100 1<k100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

Output Specification:

For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:

3
caseee1__thiiis_iiisss_a_teeeeeest

Sample Output:

ei
case1__this_isss_a_teest

Problem Analysis:

逆向思维,所有出现且只连续出现过 k k k 次及 k k k 的倍数次的字符都必定是被卡住的,但有些字符存在连续出现过 k k k 次及 k k k 的倍数次,但其他地方可能也出现过不满足上面次数的情况。我们可以遍历一遍整个句子,然后将所有一定不是被卡住的字符标记出来,然后再次遍历一遍句子,进行输出即可。详细细节见代码。

Code

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;

const int N = 200;

int st[N], k;

int main()
{
    
    
    cin >> k;
    string str;
    cin >> str;

    for (int i = 0; i < str.size(); i ++ )
    {
    
    
        int j = i + 1;
        while (j < str.size() && str[i] == str[j]) j ++ ;
        int len = j - i;
        if (len % k) st[str[i]] = 1;
        i = j - 1;
    }

    string res;
    for (int i = 0; i < str.size(); i ++ )
    {
    
    
        if (!st[str[i]]) cout << str[i], st[str[i]] = 2;
        
        if (st[str[i]] == 1) res += str[i];
            else
            {
    
    
                res += str[i];
                i += k - 1;
            }
    }

    cout << endl << res << endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/geraltofrivia123/article/details/121123496