POJ1001 HDU1063 UVA748 UVALive5356 Exponentiation【大数】

Exponentiation
Time Limit: 500MS Memory Limit: 10000K
Total Submissions: 185108 Accepted: 44559

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592 9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

Hint

If you don't know how to determine wheather encounted the end of input:
s is a string and n is an integer
C++

while(cin>>s>>n)

{

...

}

c

while(scanf("%s%d",s,&n)==2) //to see if the scanf read in as many items as you want

/while(scanf(%s%d",s,&n)!=EOF) //this also work /

{

...

}

Source

East Central North America 1988

Regionals 1988 >> North America - East Central NA

问题链接POJ1001 HDU1063 UVA748 UVALive5356 Exponentiation
问题简述:(略)
问题分析
    大数计算还是用Java来计算还是比较简单。
程序说明:(略)
参考链接:(略)
题记
    多掌握一种语言是十分必要的。

AC的Java语言程序如下:

import java.math.BigDecimal;
import java.util.Scanner;
 
public class Main {
    public static void main(String[] args){
        Scanner in = new Scanner(System.in);
        while(in.hasNext()) {
            BigDecimal r = in.nextBigDecimal();
            int n = in.nextInt();
            r = r.pow(n);
            String s = r.stripTrailingZeros().toPlainString();
            if(s.startsWith("0")) {
                s=s.substring(1);
            }
            System.out.println(s);
        }
 
    }
}

猜你喜欢

转载自www.cnblogs.com/tigerisland45/p/10389441.html