hdu1063 Exponentiation 大数求幂

Exponentiation

Time Limit: 2000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10584    Accepted Submission(s): 3102


Problem Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 
 

Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
 

Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
 

Sample Input
 
  
95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12
 

Sample Output
 
  
548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201
 

Source
import java.math.BigDecimal;
import java.util.Scanner;

public class Main{
	public static void main(String[] args){
		Scanner input = new Scanner(System.in);
		while(input.hasNext()){
			BigDecimal a = input.nextBigDecimal();
			int b = input.nextInt();
			//用string 的stripTrailingZeros() 函数去掉末尾的0
			//用toPlainString() 函数以免 ans 变为科学计数法
			String ans=a.pow(b).stripTrailingZeros().toPlainString();
			//当ans是0.xxx 这时小数点前的零不能输出,用 startsWith("0") 的方法查看第一位,
			//然后用subString(1) 重新赋值。
			if(ans.startsWith("0"))
			ans = ans.substring(1);//将ans字符串的地址定位为第二个元素开始
			System.out.println(ans);
		}
		input.close();
	}
}

猜你喜欢

转载自blog.csdn.net/cao2219600/article/details/80169637