杭电ACM1004

Let the Balloon Rise

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you. 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.
 
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 
Sample Input
 
  
5 green red blue red red 3 pink orange pink 0
Sample Output
 
  
red pink

这个题的主要思路就是比较数组中的字符串,如果字符串相同,就对应的++,再用一个数组来计数,到最后输出相同次数最多的那个字符串。

代码:

#include<iostream>
#include<string.h>
using namespace std;
int main()
{
	int count,b[1000];
	char a[1000][17];
	while(cin>>count&&count!=0)
	{
		for(int i=1;i<=count;i++)
			cin>>a[i];
		for(int i=1;i<=count;i++)
		{
			   b[i]=0;
			  for(int j=i+1;j<=count;j++)
				if(strcmp(a[i],a[j])==0)
					b[i]++;
			
		} 
		int max=b[1];
		int n=1;
		for(int i=1;i<=count;i++)
			if(b[i]>max)
			{
				max=b[i];
				n=i;
			}
			
		cout<<a[n]<<endl;
	}
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/jcl_betterman/article/details/80054768