杭电ACM2052

Problem Description
Give you the width and height of the rectangle,darw it.
 

Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
 

Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.
 

Sample Input
 
   
3 2
 

Sample Output
 
   
+---+| || |+---+
 

#include<iostream>
using namespace std;
int main(){
	int width,height;
	while(cin>>width>>height){
	cout<<"+";
	for(int i=0;i<width;i++)cout<<"-";
	cout<<"+"<<endl;
	for(int j=0;j<height;j++){
        cout<<"|";
        for(int i=0;i<width;i++)cout<<" ";
        cout<<"|"<<endl;}
	cout<<"+";
	for(int i=0;i<width;i++)cout<<"-";
	cout<<"+"<<endl;
	cout<<endl;}
	return 0;}


猜你喜欢

转载自blog.csdn.net/qq_40728285/article/details/79937467