水仙花数#acm刷题

HDU 2010

水仙花数
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 266218 Accepted Submission(s): 74680

Problem Description
春天是鲜花的季节,水仙花就是其中最迷人的代表,数学上有个水仙花数,他是这样定义的:
“水仙花数”是指一个三位数,它的各位数字的立方和等于其本身,比如:153=13+53+3^3。
现在要求输出所有在m和n范围内的水仙花数。

Input
输入数据有多组,每组占一行,包括两个整数m和n(100<=m<=n<=999)。

Output
对于每个测试实例,要求输出所有在给定范围内的水仙花数,就是说,输出的水仙花数必须大于等于m,并且小于等于n,如果有多个,则要求从小到大排列在一行内输出,之间用一个空格隔开;
如果给定的范围内不存在水仙花数,则输出no;
每个测试实例的输出占一行。

Sample Input

100 120
300 380

Sample Output

no
370 371

题目分析:
因为确定是三位数,所以我用数列存了每一位的数,然后用pow函数,若满足条件就输出,因为是i++逐步来的,所以输出时自然排好序了。要注意的是,这也是最后一个不能有空格,不然会PE,所以我用了和bool数据,来保证只有数据间有空格。

AC的c++代码
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
	int m=0, n=0;
	while (cin >> m >> n)
	{
		bool work = 0;
		bool does = 0;
		for (int i = m; i <= n; i++)
		{
			int a[3];
			a[0] = i / 100;
			a[1] = i / 10 - a[0] * 10;
			a[2] = i % 10;
			int he = pow(a[0], 3) + pow(a[1], 3) + pow(a[2], 3);
			if (he == i)
			{
				if (does)
					cout << " ";
				cout << he;
				work = 1;
				does = 1;
			}
		}
		if(work==0)
		{
			cout << "no";
		}
		cout << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43316754/article/details/85040945