12 H

POJ 2421
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

    Input
    
  
   The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

    Output
    
  
   You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
  

    Sample Input
    3

0 990 692
990 0 179
692 179 0
1
1 2

    Sample Output
    179

给的数刚好是距离表需要的数,直接用克鲁斯卡尔算法搞定。

#include<algorithm>
#include <iostream>
using namespace std;

struct path
{
	int x, y, w;
}a[10005];
int f[100005];
int cmp(path a, path b)
{
	return a.w < b.w;
}
int find(int x)
{
	if (f[x] != x)f[x] = find(f[x]);
	return f[x];
}
void merge(int a, int b)
{
	int A, B;
	A = find(a);
	B = find(b);
	if (A != B)
		f[B] = A;
}
int main()
{
	int n;
	while (cin >> n)
	{
		if (n == 0)break;
		for (int i = 1; i <= n; i++)f[i] = i;
		int m = 0;
		for (int i = 1; i <= n; i++)
			for (int t = 1; t <= n; t++)
			{
				a[m].x = i; a[m].y = t;
				cin >> a[m].w;
				m++;
			}
		sort(a, a + m, cmp);
		int d, b, c;
		cin >> d;
		while (d--)
		{
			cin >> b >> c;
			merge(b, c);
		}
		int s = 0;
		for (int i = 0; i < m; i++)
		{
			if (find(a[i].x) != find(a[i].y))
			{
				merge(a[i].x, a[i].y);
				s += a[i].w;
			}
		}
		cout << s << endl;
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_43976373/article/details/86683563
今日推荐