9 H

UVA 11389

In a city there are n bus drivers. Also there are n morning bus routes and n afternoon bus routes with various lengths. Each driver is assigned one morning route and one evening route. For any driver, if his total route length for a day exceeds d, he has to be paid overtime for every hour after the first d hours at a flat r taka / hour. Your task is to assign one morning route and one evening route to each bus driver so that the total overtime amount that the authority has to pay is minimized.
Input
The first line of each test case has three integers n, d and r, as described above. In the second line, there are n space separated integers which are the lengths of the morning routes given in meters. Similarly the third line has n space separated integers denoting the evening route lengths. The lengths are positive integers less than or equal to 10000. The end of input is denoted by a case with three 0’s.
Output
For each test case, print the minimum possible overtime amount that the authority must pay.
Constraints • 1 ≤ n ≤ 100 • 1 ≤ d ≤ 10000 • 1 ≤ r ≤ 5
Sample Input
2 20 5 10 15 10 15 2 20 5 10 10 10 10 0 0 0
Sample Output
50 0

#include<algorithm>
#include <iostream>
using namespace std;

bool com(int a, int b)
{
	return a > b;
}
bool con(int a, int b)
{
	return a < b;
}
int main()
{
	int n, m, p, q, s;
	int z[101], w[101];
	while (cin >> n >> m >> p)
	{
		if (n == 0)break;
		s = 0;
		for (int i = 0; i < n; i++)
			cin >> z[i];
		for (int i = 0; i < n; i++)
			cin >> w[i];
		sort(z, z + n, con);
		sort(w, w + n, com);
		for (int i = 0; i < n; i++)
		{
			if (z[i] + w[i] > m)s = s + (z[i] + w[i]) - m;
		}
		cout << s * p << endl;
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_43976373/article/details/86683899
9 H
9-8
9-1
9-5
9-6
9-3
9-7