模拟_1080 Graduate Admission (30 分)

1080 Graduate Admission (30 分)

It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade G​E​​, and the interview grade G​I​​. The final grade of an applicant is (G​E​​+G​I​​)/2. The admission rules are:

  • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.

  • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade G​E​​. If still tied, their ranks must be the same.

  • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.

  • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case.

Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's G​E​​ and G​I​​, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M−1, and the applicants are numbered from 0 to N−1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:

11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4

Sample Output:

0 10
3
5 6 7
2 8

1 4

题目意思:

有n个学生,m个学校,每个人可以填报的志愿为k个,每个人有两个成绩,笔试成绩GE,口试成绩GI,排名按照GE和GI的平均值计算,如果平均值相同,则按照GE排序,如果GE相同,则两学生排名相同

学校的录取规则为:按照成绩排序,再按照每一个 学生填报志愿的顺序,一次向下进行学校判断,如果学校没有收满学生,则录取,如果已经收满学生,但是最后一名收的学生和当前学生排名相同,即使名额超限,也会录取该学生

根据上述描述直接写模拟程序即可

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <cmath>
#include <map>
#include <stack>
#include <vector>
#include <algorithm>
#define INF 0x3f3f3f3f

using namespace std;
const int maxm = 105;
const int maxn = 40000+100;
int n,m,k;
int num[maxm],app[maxn][7],GE[maxn],GI[maxn];
struct student
{
    int score,pos;
    bool operator<(const student a)const
    {
        if(score == a.score)
            return GE[pos]>GE[a.pos];
        return score > a.score;
    }
}stu[maxn];
vector<int> vec[maxm];   //存储学校招收学生的序号

int main()
{
    scanf("%d%d%d",&n,&m,&k);
    for(int i =0 ;i < m;i ++)
        scanf("%d",num+i);    //每个学校的额度
    for(int i =0 ;i < n;i ++)
    {
        scanf("%d%d",GE+i,GI+i);
        stu[i].score = GE[i] + GI[i];
        stu[i].pos = i;
        for(int j = 0;j < k;j ++)
            scanf("%d",&app[i][j]);
    }
    sort(stu,stu+n);
    bool flag = false;
    for(int i =0 ;i < n;i ++)
    {
        flag = false;
        for(int j = 0;j < k;j ++)
        {
            int pos = stu[i].pos;
            int sc = app[pos][j];
            if(num[sc] > 0)
            {
                num[sc] --;
                vec[sc].push_back(pos);
                flag = true;
            }
            else
            {
                if(!vec[sc].empty())
                {
                    int a = vec[sc][vec[sc].size()-1];
                    if(GE[a]+GI[a] == GE[pos]+GI[pos] && GE[a] == GE[pos])
                    {
                        vec[sc].push_back(pos);
                        flag = true;
                    }
                }
            }
            if(flag)
                break;
        }
    }
    for(int i =0 ;i < m;i ++)
    {
        if(vec[i].size() != 0)
            sort(vec[i].begin(),vec[i].end()),printf("%d",vec[i][0]);
        for(int j = 1;j < vec[i].size();j ++)
            printf(" %d",vec[i][j]);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/li1615882553/article/details/86380237
今日推荐