PAT A1080 Graduate Admission (30分)

题目链接https://pintia.cn/problem-sets/994805342720868352/problems/994805387268571136

题目描述
It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade G​E​​ , and the interview grade G​I​​ . The final grade of an applicant is (G​E​​ +G​I​​ )/2. The admission rules are:

The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.

If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade G​E​​ . If still tied, their ranks must be the same.

Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one’s turn to be admitted; and if the quota of one’s most preferred shcool is not exceeded, then one will be admitted to this school, or one’s other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.

If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

输入
Each input file contains one test case.

Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant’s G​E​​ and G​I​​ , respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M−1, and the applicants are numbered from 0 to N−1.

扫描二维码关注公众号,回复: 10061153 查看本文章

输出
For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants’ numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

样例输入
11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4

样例输出
0 10
3
5 6 7
2 8

1 4

代码

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

struct student{
	int id;
	int ge;
	int gi;
	int sum;
	int rank;
	int apply[100];
}stu[40110];

struct school {
	int num;
	int now;
	int enter_stu[100];
	int last_rank;
}sch[110] = {0};

bool cmp1(student a, student b) {
	if(a.sum != b.sum)
		return a.sum > b.sum;
	else
		return a.ge > b.ge;
}

int main() {
	int n, m, k;
	scanf("%d%d%d", &n, &m, &k);
	for(int i = 0; i < m; i++)
		scanf("%d", &sch[i].num);
	for(int i = 0; i < n; i++) {
		scanf("%d%d", &stu[i].ge, &stu[i].gi);
		stu[i].id = i;
		stu[i].sum = stu[i].ge + stu[i].gi;
		for(int j = 0; j < k; j++)
			scanf("%d", &stu[i].apply[j]);
	}
	sort(stu, stu + n, cmp1);
	stu[0].rank = 1;
	for(int i = 1; i < n; i++) {
		if(stu[i].sum != stu[i - 1].sum || stu[i].ge != stu[i - 1].ge)
			stu[i].rank = i + 1;
		else 
			stu[i].rank = stu[i - 1].rank;
	}
	for(int i = 0; i < n; i++) {
		for(int j = 0; j < k; j++) {
			int p = stu[i].apply[j];
			if(sch[p].num - sch[p].now > 0 || stu[i].rank == sch[p].last_rank) {
				sch[p].enter_stu[sch[p].now++] = stu[i].id;
				sch[p].last_rank = stu[i].rank;
				break;
			}
		}
	}
	for(int i = 0; i < m; i++) {
		if(sch[i].num == 0)
			printf("\n");
		else {
			sort(sch[i].enter_stu, sch[i].enter_stu + sch[i].now);
			for(int j = 0; j < sch[i].now; j++) {
                if(j)
                    printf(" ");
				printf("%d", sch[i].enter_stu[j]);
            }
			printf("\n");
		}
	}
	return 0;
}

【注】:第四个case答案错误,暂未找到原因。

发布了288 篇原创文章 · 获赞 12 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/Rhao999/article/details/104714920