F - Count the Colors ZOJ - 1610 (线段树加区间染色)

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.

Input



The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.

Output



Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

If some color can't be seen, you shouldn't print it.

Print a blank line after every dataset.

Sample Input



5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1

Sample Output



1 1
2 1
3 1

1 1

0 2
1 1

题意:给了每一线段的颜色,存在颜色覆盖,求表面上看能看到的颜色种类和各种颜色的段数

//ffÇřĽäȾɫ
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn=8000+10;
struct node
{
	int l,r,sum;
}a[4*maxn];
int x1[maxn],x2[maxn],c[maxn];
int mark[maxn];
int sum[maxn];
int lenn; 
void build(int o,int l,int r)
{
	a[o].l=l,a[o].r=r,a[o].sum=-1;
	int ls=o<<1,rs=o<<1|1,mid=(l+r>>1);
	if(l==r)
	{
		a[o].sum=-1;
		return ;
	}
	build(ls,l,mid);
	build(rs,mid+1,r);
}
void pushdown(int o)
{
	   if(a[o].sum!=-1)
	   {
	   		a[o<<1].sum=a[o].sum;
	   		a[o<<1|1].sum=a[o].sum;
	   		a[o].sum=-1;
	   }
}
void update(int o,int l,int r,int c)
{
	int ls=o<<1,rs=o<<1|1,mid=(a[o].l+a[o].r)>>1;
	if(l<=a[o].l&&a[o].r<=r)
	{
		a[o].sum=c;
		return ;
	}
	pushdown(o);
	if(l<=mid) update(ls,l,r,c);
	if(r>mid) update(rs,l,r,c);
}
void query(int o,int l,int r)
{
	int ls=o<<1,rs=o<<1|1,mid=(a[o].l+a[o].r)>>1;
	if(a[o].l==a[o].r)
	{
		mark[lenn++]=a[o].sum;
		return ;
	}
	pushdown(o);
	if(l<=mid) query(ls,l,r);
	if(r>mid) query(rs,l,r);
}
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		int maxx=0;
		for(int i=0;i<n;i++)
		{
			scanf("%d%d%d",&x1[i],&x2[i],&c[i]);
			int x=max(x1[i]+1,x2[i]);
			maxx=max(maxx,x);
		}
		memset(mark,-1,sizeof(mark));
		build(1,1,maxx);
		for(int i=0;i<n;i++)	update(1,x1[i]+1,x2[i],c[i]);
		lenn=0;
		query(1,1,maxx);
		int x;
		memset(sum,0,sizeof(sum));
		for(int i=0;i<lenn;)
		{
			if(mark[i]==-1)	
			{
				i++;
				continue;
			}
			x=mark[i];
			while(x==mark[++i]&&i<lenn) ;
			sum[x]++;
		}
		for(int i=0;i<=maxx+10;i++)
		{
			if(sum[i]!=0)
				printf("%d %d\n",i,sum[i]);
		}
		printf("\n");
	}
} 

猜你喜欢

转载自blog.csdn.net/qq_41286356/article/details/85946857
今日推荐