acm新手训练题(Climbing Worm)

Problem Description

An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We’ll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we’ll assume the worm makes it out.
Input

There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.
Output

Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
Sample Input

10 2 1
20 3 1
0 0 0
Sample Output

17
19
题解:如果向上爬后未到到达顶点,则滑下在上去需要两次,依次类推。

#include<cmath>
using namespace std;
int main()
{
	int a, b, n, i, j;
	while(cin>>n)
	{
		if (n > 0)
		{
			j = 0;
			cin >> a >> b;
			for(i=n;i>0;)
			{
				i = i - a;
				if(i>0)
				{
					i = i + b;
					j = j + 2;
				}
				else j++;
			}
		}
		else break; cout << j << endl;
	}
	
}
在这里插入代码片

猜你喜欢

转载自blog.csdn.net/weixin_43965698/article/details/85008980
今日推荐