PAT 甲级 1026 Table Tennis

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/a845717607/article/details/86586453

1026 Table Tennis (30 point(s))

A table tennis club has N tables available to the public. The tables are numbered from 1 to N. For any pair of players, if there are some tables open when they arrive, they will be assigned to the available table with the smallest number. If all the tables are occupied, they will have to wait in a queue. It is assumed that every pair of players can play for at most 2 hours.

Your job is to count for everyone in queue their waiting time, and for each table the number of players it has served for the day.

One thing that makes this procedure a bit complicated is that the club reserves some tables for their VIP members. When a VIP table is open, the first VIP pair in the queue will have the priviledge to take it. However, if there is no VIP in the queue, the next pair of players can take it. On the other hand, if when it is the turn of a VIP pair, yet no VIP table is available, they can be assigned as any ordinary players.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (≤10000) - the total number of pairs of players. Then N lines follow, each contains 2 times and a VIP tag: HH:MM:SS - the arriving time, P - the playing time in minutes of a pair of players, and tag - which is 1 if they hold a VIP card, or 0 if not. It is guaranteed that the arriving time is between 08:00:00 and 21:00:00 while the club is open. It is assumed that no two customers arrives at the same time. Following the players' info, there are 2 positive integers: K (≤100) - the number of tables, and M (< K) - the number of VIP tables. The last line contains Mtable numbers.

Output Specification:

For each test case, first print the arriving time, serving time and the waiting time for each pair of players in the format shown by the sample. Then print in a line the number of players served by each table. Notice that the output must be listed in chronological order of the serving time. The waiting time must be rounded up to an integer minute(s). If one cannot get a table before the closing time, their information must NOT be printed.

Sample Input:

9
20:52:00 10 0
08:00:00 20 0
08:02:00 30 0
20:51:00 10 0
08:10:00 5 0
08:12:00 10 1
20:50:00 10 0
08:01:30 15 1
20:53:00 10 1
3 1
2

Sample Output:

08:00:00 08:00:00 0
08:01:30 08:01:30 0
08:02:00 08:02:00 0
08:12:00 08:16:30 5
08:10:00 08:20:00 10
20:50:00 20:50:00 0
20:51:00 20:51:00 0
20:52:00 20:52:00 0
3 3 2

Experiential Summing-up

This question is a simulation of occupy table tennis. The hard point is how to arrange who for which table tennis. If I meet this question in the exam. I can't work it out perfectly. So, relax, don't put in you mind if you can't handle it well. (Da lao please ignore it).
Attention: First, wait time is not ceil up to a integer but round(四舍五入) up to a integer.  Secondly, though it is guaranteed that the arriving time is between 08:00:00 and 21:00:00 while the club is open. we still need cope with whose arrive time later than 21:00:00. Thirdly, the sever time is not more than 2 hours. Finally, it's convenient to convert HH:mm:ss to a integer in the calculation of time.

 (The purpose of using English to portray my solution is that to exercise the ability of my expression of English and accommodate PAT advanced level's style.We can make progress together by reading and comprehending it. Please forgive my basic grammar's and word's error. Of course, I would appreciated it if you can point out my grammar's and word's error in comment section.( •̀∀•́ ) Furthermore, Big Lao please don't laugh at me because I just a English beginner settle for CET6    _(:з」∠)_  )

Accepted Code

#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
#include <queue>
#include <cmath>
using namespace std;
bool isvip[110]={false};
int table[110],num[110]={0},k;

struct player
{
	int arrive,start,server,wait,f;
};
vector<player> ans;
int convert(int h,int m,int s)
{
	return h*3600+m*60+s;
}
int start=convert(8,0,0),endt=convert(21,0,0);
bool cmp(player a,player b)
{
	return a.arrive<b.arrive;
}
bool cmp1(player a,player b)
{
	return a.start<b.start;
}
int search(int f)
{
	int index=-1,min=endt;
	for(int i=1;i<=k;++i)
	{
		if(table[i]<min)
		{
			if(f==1&&isvip[i]==true||f==0)
			{
				index=i;
				min=table[i];
			}
		}
	}
	return index;
}
int nextvip(int v)
{
	++v;
	while(v<ans.size()&&ans[v].f==0)
		++v;
	return v;
}
void allocate(int w,int &pos)
{
	if(ans[pos].arrive>table[w])
		ans[pos].start=ans[pos].arrive;
	else
		ans[pos].start=table[w];
	table[w]=ans[pos].start+ans[pos].server;
	ans[pos].wait=(int)floor((ans[pos].start-ans[pos].arrive)/60.0+0.5);
	++num[w];
}
int main()
{
	int n,h,m,s,t,f;
	scanf("%d",&n);
	for(int i=0;i<n;++i)
	{
		scanf("%d:%d:%d %d %d",&h,&m,&s,&t,&f);
		player a;
		a.arrive=convert(h,m,s);
		if(a.arrive>=endt)
			continue;
		a.server=t<=120?t*60:7200;
		a.start=endt;
		a.f=f;
		ans.push_back(a);
	}
	sort(ans.begin(),ans.end(),cmp);
	scanf("%d %d",&k,&m);
	for(int i=0;i<m;++i)
	{
		scanf("%d",&t);
		isvip[t]=true;
	}
	for(int i=1;i<=k;++i)
		table[i]=start;
	int vpos=nextvip(-1),cpos=0;
	while(cpos<ans.size())
	{
		int x=search(0);
		if(x==-1)
			break;
		if(ans[cpos].f==1&&cpos<vpos)
		{
			++cpos;
			continue;
		}
		if(isvip[x]==1)
		{
			if(ans[cpos].f==1)
			{
				allocate(x,cpos);
				vpos=nextvip(vpos);
				++cpos;
			}
			else
			{
				if(vpos<ans.size()&&ans[vpos].arrive<=table[x])
				{
					allocate(x,vpos);
					vpos=nextvip(vpos);
				}
				else
				{
					allocate(x,cpos);
					++cpos;
				}
			}
		}
		else
		{
			if(ans[cpos].f==1)
			{
				int w=search(1);
				if(w!=-1&&table[w]<=ans[cpos].arrive)
					allocate(w,cpos);
				else
					allocate(x,cpos);
				vpos=nextvip(vpos);
			}
			else
				allocate(x,cpos);
			++cpos;
		}
	}
	sort(ans.begin(),ans.end(),cmp1);
	for(int i=0;i<ans.size()&&ans[i].start<convert(21,0,0);++i)
	{
		printf("%02d:%02d:%02d %02d:%02d:%02d %d\n",ans[i].arrive/3600,(ans[i].arrive%3600)/60,ans[i].arrive%60,ans[i].start/3600,(ans[i].start%3600)/60,ans[i].start%60,ans[i].wait);
	}
	for(int i=1;i<=k;++i)
	{
		printf("%d",num[i]);
		if(i!=k)
			printf(" ");
		else
			printf("\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/a845717607/article/details/86586453
今日推荐