B1038 统计同成绩学生 (20 分)

本题要求读入 N 名学生的成绩,将获得某一给定分数的学生人数输出。

输入格式:

输入在第 1 行给出不超过 10​5​​ 的正整数 N,即学生总人数。随后一行给出 N 名学生的百分制整数成绩,中间以空格分隔。最后一行给出要查询的分数个数 K(不超过 N 的正整数),随后是 K 个分数,中间以空格分隔。

输出格式:

在一行中按查询顺序给出得分等于指定分数的学生人数,中间以空格分隔,但行末不得有多余空格。

输入样例:

10
60 75 90 55 75 99 82 90 75 50
3 75 90 88

输出样例:

3 2 0

注意:

  1.  基于散列的思想,所有数字不超过100,定义 int 型哈希数组
#include <cstdio>
int hashTable[110] = {0};
int main(){
  int n, score;
  scanf("%d", &n);
  for(int i = 0; i < n; i++){
    scanf("%d", &score);
    hashTable[score]++;
  }
  scanf("%d", &n);
  for(int i = 0; i < n; i++){
    scanf("%d", &score);
    printf("%d", hashTable[score]);
    if(i < n - 1)
      printf(" ");
  }
}

猜你喜欢

转载自blog.csdn.net/weixin_35093872/article/details/86592896