PTA 1038 统计同成绩学生 (20分) (python 3)

本题要求读入 N 名学生的成绩,将获得某一给定分数的学生人数输出。
输入格式:
输入在第 1 行给出不超过 10​5​​ 的正整数 N,即学生总人数。随后一行给出 N 名学生的百分制整数成绩,中间以空格分隔。最后一行给出要查询的分数个数 K(不超过 N 的正整数),随后是 K 个分数,中间以空格分隔。
输出格式:
在一行中按查询顺序给出得分等于指定分数的学生人数,中间以空格分隔,但行末不得有多余空格。
输入样例:
10
60 75 90 55 75 99 82 90 75 50
3 75 90 88
输出样例:
3 2 0

代码

n=int(input())
grade={}
temp=input().split()
for i in range(n):
    if temp[i] in grade:
        grade[temp[i]]+=1
    else:
        grade[temp[i]]=1
temp=input().split()
x=len(temp)
for i in range(1,x):
    if temp[i] in grade :
        if i != x-1:
            print(grade[temp[i]],end=' ')
        else:
            print(grade[temp[i]])
    else:
        if i == x-1:
            print(0)
        else:
            print(0,end=' ')

题目不难,就是这个格式搞人,要注意一下范围!

发布了9 篇原创文章 · 获赞 0 · 访问量 174

猜你喜欢

转载自blog.csdn.net/qq_46258819/article/details/104591910