POJ No.2386 Lake Counting(DFS与BFS两种解法)

Lake Counting

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 48096   Accepted: 23633

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

题意:有一个大小为NxM的园子,雨后积起了水。连通的积水被认为是连接在一起的。请求出园子里有多少水洼?

解法一:DFS

#include<stdio.h>

char field[101][101];
int n,m;

void DFS(int x,int y)
{
    field[x][y]='.';
    for(int i=-1;i<=1;i++)
        for(int j=-1;j<=1;j++)
        {
            int curx=x+i;
            int cury=y+j;
            if(curx>=0&&curx<=n&&cury>=0&&cury<=m&&field[curx][cury]=='W')
                DFS(curx,cury);
        }
        return;
}

int main()
{
    int ans=0;
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++)
    {
        getchar();
        for(int j=0;j<m;j++)
        {
            scanf("%c",&field[i][j]);
        }
    }
    for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
        {
            if(field[i][j]=='W')
                {
                    DFS(i,j);
                    ans++;
                }
        }
     printf("%d",ans);
     return 0;
}

解法二:BFS

#include<stdio.h>
#include<queue>
#include<utility>
using namespace std;

char field[101][101];
int n,m;
typedef pair<int,int> P;

void BFS(int x,int y)
{
    queue<P> que;
    que.push(P(x,y));
    while(!que.empty())
    {
        P p=que.front();
        que.pop();
        for(int i=-1;i<=1;i++)
            for(int j=-1;j<=1;j++)
            {
                int curx=p.first+i,cury=p.second+j;
                if(curx>=0&&curx<=n&&cury>=0&&cury<=m&&field[curx][cury]=='W')
                {
                    field[curx][cury]='.';
                    que.push(P(curx,cury));
                }
            }
    }
}

int main()
{
    int ans = 0;
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++)
    {
        getchar();
        for(int j=0;j<m;j++)
        {
            scanf("%c",&field[i][j]);
        }
    }
    for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
        {
            if(field[i][j]=='W')
            {
                BFS(i,j);
                ans++;
            }
        }
     printf("%d",ans);

     return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41706331/article/details/86606050
今日推荐