【HDU】5493Queue-(树状数组+二分查找)

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1570    Accepted Submission(s): 808


 

Problem Description

N people numbered from 1 to N are waiting in a bank for service. They all stand in a queue, but the queue never moves. It is lunch time now, so they decide to go out and have lunch first. When they get back, they don’t remember the exact order of the queue. Fortunately, there are some clues that may help.
Every person has a unique height, and we denote the height of the i -th person as hi . The i -th person remembers that there were ki people who stand before him and are taller than him. Ideally, this is enough to determine the original order of the queue uniquely. However, as they were waiting for too long, some of them get dizzy and counted ki in a wrong direction. ki could be either the number of taller people before or after the i -th person.
Can you help them to determine the original order of the queue?

 

Input

The first line of input contains a number T indicating the number of test cases (T≤1000 ).
Each test case starts with a line containing an integer N indicating the number of people in the queue (1≤N≤100000 ). Each of the next N lines consists of two integers hi and ki as described above (1≤hi≤109,0≤ki≤N−1 ). Note that the order of the given hi and ki is randomly shuffled.
The sum of N over all test cases will not exceed 106

 

Output

For each test case, output a single line consisting of “Case #X: S”. X is the test case number starting from 1. S is people’s heights in the restored queue, separated by spaces. The solution may not be unique, so you only need to output the smallest one in lexicographical order. If it is impossible to restore the queue, you should output “impossible” instead.

 

Sample Input

 

3 3 10 1 20 1 30 0 3 10 0 20 1 30 0 3 10 0 20 0 30 1

 

Sample Output

 

Case #1: 20 10 30 Case #2: 10 20 30 Case #3: impossible

 

Source

2015 ACM/ICPC Asia Regional Hefei Online

 

Recommend

wange2014

 

思路转载自:http://www.cnblogs.com/zhangchengc919/p/5951261.html

谢谢大神!!!!

题意:给出n个人的高度,以及这个人前面或者后面有多少个比她高,现在让你求字典序最小的队列的身高;

思路:排序后可以得到这个队列中比某个人高的总人数假设是num,如果num<k比这个总人数还多的话就不可能了;

然后我们把这个k变成前边的比她高的人数,这个k是min(k,num-k)这样保证了字典序最小;

然后就是求每个位置上的身高呢,将身高从小大排序,这就是相当于给了一个序列的逆序数,然后让你还原这个序列了;

从小到大贪心,对于每个人二分她的位置,确定后更新到树状数组中,复杂度O(n*log2n);

#include <bits/stdc++.h>
using namespace std; 
typedef long long LL;
const int maxn=1e5+10;
int n,ans[maxn],sum[maxn],hi[maxn];
struct node
{
    int h,k,id;
}po[maxn];
int cmp(node a,node b){return a.h>b.h;}
int cmp1(node a,node b)
{
    if(a.h==b.h)return a.k<b.k;
    return a.h<b.h;
}
inline int lowbit(int x){return x&(-x);}
inline void update(int x)
{
    while(x<=n)
    {
        sum[x]++;
        x+=lowbit(x);
    }
}
inline int query(int x)
{
    int s=0;
    while(x)
    {
        s+=sum[x];
        x-=lowbit(x);
    }
    return s;
}
int main() 
{ 
    int t,Case=0;
    scanf("%d",&t);
    while(t--)
    {
        printf("Case #%d:",++Case);
        scanf("%d",&n);
        for(int i=1;i<=n;i++)scanf("%d%d",&po[i].h,&po[i].k),po[i].id=i;
        sort(po+1,po+n+1,cmp);
        int flag=0,num=0;po[0].h=-1;
        for(int i=1;i<=n;i++)
        {
            if(po[i].h!=po[i-1].h)num=i-1;
            if(po[i].k>num){flag=1;break;}
            hi[i]=num;
        }
        if(flag)printf(" impossible\n");
        else
        {
            for(int i=1;i<=n;i++)po[i].k=min(po[i].k,hi[i]-po[i].k),sum[i]=0;
            sort(po+1,po+n+1,cmp1);
            for(int i=1;i<=n;i++)
            {
                int l=po[i].k+1,r=n;
                while(l<=r)
                {
                    int mid=(l+r)>>1;
                    if(mid-query(mid)>po[i].k)r=mid-1;
                    else l=mid+1;
                }
                ans[r+1]=po[i].h;
                update(r+1);
            }
            for(int i=1;i<=n;i++)printf(" %d",ans[i]);
            printf("\n");
        }
    }
    return 0; 
} 

猜你喜欢

转载自blog.csdn.net/wentong_Xu/article/details/86531533