hdu - 4122 Alice's mooncake shop【单调队列】

Alice's mooncake shop

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4678    Accepted Submission(s): 1257


 

Problem Description

The Mid-Autumn Festival, also known as the Moon Festival or Zhongqiu Festival is a popular harvest festival celebrated by Chinese people, dating back over 3,000 years to moon worship in China's Shang Dynasty. The Zhongqiu Festival is held on the 15th day of the eighth month in the Chinese calendar, which is in September or early October in the Gregorian calendar. It is a date that parallels the autumnal equinox of the solar calendar, when the moon is at its fullest and roundest. 


The traditional food of this festival is the mooncake. Chinese family members and friends will gather to admire the bright mid-autumn harvest moon, and eat mooncakes under the moon together. In Chinese, “round”(圆) also means something like “faultless” or “reuion”, so the roundest moon, and the round mooncakes make the Zhongqiu Festival a day of family reunion.

Alice has opened up a 24-hour mooncake shop. She always gets a lot of orders. Only when the time is K o’clock sharp( K = 0,1,2 …. 23) she can make mooncakes, and We assume that making cakes takes no time. Due to the fluctuation of the price of the ingredients, the cost of a mooncake varies from hour to hour. She can make mooncakes when the order comes,or she can make mooncakes earlier than needed and store them in a fridge. The cost to store a mooncake for an hour is S and the storage life of a mooncake is T hours. She now asks you for help to work out a plan to minimize the cost to fulfill the orders.

 

Input

The input contains no more than 10 test cases. 
For each test case:
The first line includes two integers N and M. N is the total number of orders. M is the number of hours the shop opens. 
The next N lines describe all the orders. Each line is in the following format:

month date year H R

It means that on a certain date, a customer orders R mooncakes at H o’clock. “month” is in the format of abbreviation, so it could be "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct", "Nov" or "Dec". H and R are all integers. 
All the orders are sorted by the time in increasing order. 
The next line contains T and S meaning that the storage life of a mooncake is T hours and the cost to store a mooncake for an hour is S.
Finally, M lines follow. Among those M lines, the ith line( i starts from 1) contains a integer indicating the cost to make a mooncake during the ith hour . The cost is no more than 10000. Jan 1st 2000 0 o'clock belongs to the 1st hour, Jan 1st 2000 1 o'clock belongs to the 2nd hour, …… and so on.

(0<N <= 2500; 0 < M,T <=100000; 0<=S <= 200; R<=10000 ; 0<=H<24)

The input ends with N = 0 and M = 0.

 

扫描二维码关注公众号,回复: 4996430 查看本文章

Output

You should output one line for each test case: the minimum cost. 

 

Sample Input

 

1 10 Jan 1 2000 9 10 5 2 20 20 20 10 10 8 7 9 5 10 0 0

 

Sample Output

 

70

Hint

“Jan 1 2000 9 10” means in Jan 1st 2000 at 9 o'clock , there's a consumer ordering 10 mooncakes. Maybe you should use 64-bit signed integers. The answer will fit into a 64-bit signed integer.

 

Source

2011 Asia Fuzhou Regional Contest

 

Recommend

lcy

把所有定单的时间转为小时单位,然后对每个时间点的最小值用单调队列维护。

因为对于每个时间点相对于每个订单的时间不一样,所以需要将其转化一下。

对于i时间点生产的月饼,直接维护其存储到M时间所需的费用,即 b[i]+(m-i)*s ,计算ans时再减去(m-i)*s。

#include "cstdio"
#include "cstring"
#include "queue"
#include "iostream"
#include "vector"
#include "algorithm"
#include "map"
#include "deque"
using namespace std;
const long long inf = 8e18;
int md[15]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int month(string s)
{
    if(s=="Jan")return 1;
    else if(s=="Feb")return 2;
    else if(s=="Mar")return 3;
    else if(s=="Apr")return 4;
    else if(s=="May")return 5;
    else if(s=="Jun")return 6;
    else if(s=="Jul")return 7;
    else if(s=="Aug")return 8;
    else if(s=="Sep")return 9;
    else if(s=="Oct")return 10;
    else if(s=="Nov")return 11;
    else if(s=="Dec")return 12;
}
long long gettime(int y,int m,int d,int h)
{
    long long ans=0;
    for (int i = 2000; i < y; ++i) {
        if(i%400==0||(i%4==0&&i%100!=0))ans+=366;
        else ans+=365;
    }

    for (int i = 1; i < m; ++i) {
        if(i==2&&(y%400==0||(y%4==0&&y%100!=0)))ans+=29;
        else ans+=md[i];
    }
    return (ans+d-1)*24+h;
}
struct order
{
    int t,r;
}a[3000];
int b[100004];
struct node
{
    long long w;
    int maxtime;
};
deque<node>q;
int main()
{
    int n,m,t,s;
    while(cin>>n>>m,(n+m))
    {
        string mm;
        int d,y,h,r;
        for (int i = 1; i <= n; ++i) {
            cin>>mm;
            scanf("%d%d%d%d",&d,&y,&h,&r);
            a[i]={gettime(y,month(mm),d,h),r};
        }
        scanf("%d%d",&t,&s);
        for (int i = 0; i < m; ++i) {
            scanf("%d",&b[i]);
        }
        q.clear();
        int cnt=1;
        long long ans=0;
        for (int i = 0; i < m; ++i) {
            while(q.size()&&q.front().maxtime<i)q.pop_front();
            while(q.size()&&q.back().w>=(b[i]+s*(m-i)))q.pop_back();
            q.push_back({b[i]+s*(m-i),i+t});
            while(a[cnt].t==i)
            {
                ans+=(q.front().w-(m-i)*s)*a[cnt].r;
                cnt++;
            }
            if(cnt>n)break;
        }
        printf("%lld\n",ans);
    }
}

猜你喜欢

转载自blog.csdn.net/qq_42671946/article/details/86162352