[USACO08FEB]酒店Hotel 线段树 BZOJ 1593

题目描述

The cows are journeying north to Thunder Bay in Canada to gain cultural enrichment and enjoy a vacation on the sunny shores of Lake Superior. Bessie, ever the competent travel agent, has named the Bullmoose Hotel on famed Cumberland Street as their vacation residence. This immense hotel has N (1 ≤ N ≤ 50,000) rooms all located on the same side of an extremely long hallway (all the better to see the lake, of course).

The cows and other visitors arrive in groups of size Di (1 ≤ Di ≤ N) and approach the front desk to check in. Each group i requests a set of Di contiguous rooms from Canmuu, the moose staffing the counter. He assigns them some set of consecutive room numbers r..r+Di-1 if they are available or, if no contiguous set of rooms is available, politely suggests alternate lodging. Canmuu always chooses the value of r to be the smallest possible.

Visitors also depart the hotel from groups of contiguous rooms. Checkout i has the parameters Xi and Di which specify the vacating of rooms Xi ..Xi +Di-1 (1 ≤ Xi ≤ N-Di+1). Some (or all) of those rooms might be empty before the checkout.

Your job is to assist Canmuu by processing M (1 ≤ M < 50,000) checkin/checkout requests. The hotel is initially unoccupied.

参考样例,第一行输入n,m ,n代表有n个房间,编号为1---n,开始都为空房,m表示以下有m行操作,以下 每行先输入一个数 i ,表示一种操作:

若i为1,表示查询房间,再输入一个数x,表示在1--n 房间中找到长度为x的连续空房,输出连续x个房间中左端的房间号,尽量让这个房间号最小,若找不到长度为x的连续空房,输出0。

若i为2,表示退房,再输入两个数 x,y 代表 房间号 x---x+y-1 退房,即让房间为空。

输入输出格式

输入格式:

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Line i+1 contains request expressed as one of two possible formats: (a) Two space separated integers representing a check-in request: 1 and Di (b) Three space-separated integers representing a check-out: 2, Xi, and Di

输出格式:

* Lines 1.....: For each check-in request, output a single line with a single integer r, the first room in the contiguous sequence of rooms to be occupied. If the request cannot be satisfied, output 0.

输入输出样例

输入样例#1: 复制
10 6
1 3
1 3
1 3
1 3
2 5 5
1 6
输出样例#1: 复制
1
4
7
0
5

lmax 指从左起最长的空闲房间数,同理对于rmax;
sum指一个区间的最长空闲数;
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<set>
#include<vector>
#include<queue>
#include<bitset>
#include<ctime>
#include<deque>
#include<stack>
#include<functional>
#include<sstream>
//#include<cctype>
//#pragma GCC optimize(2)
using namespace std;
#define maxn 1000005
#define inf 0x7fffffff
//#define INF 1e18
#define rdint(x) scanf("%d",&x)
#define rdllt(x) scanf("%lld",&x)
#define rdult(x) scanf("%lu",&x)
#define rdlf(x) scanf("%lf",&x)
#define rdstr(x) scanf("%s",x)
typedef long long  ll;
typedef unsigned long long ull;
typedef unsigned int U;
#define ms(x) memset((x),0,sizeof(x))
const long long int mod = 1e9 + 7;
#define Mod 1000000000
#define sq(x) (x)*(x)
#define eps 1e-4
typedef pair<int, int> pii;
#define pi acos(-1.0)
//const int N = 1005;
#define REP(i,n) for(int i=0;i<(n);i++)
typedef pair<int, int> pii;
inline ll rd() {
	ll x = 0;
	char c = getchar();
	bool f = false;
	while (!isdigit(c)) {
		if (c == '-') f = true;
		c = getchar();
	}
	while (isdigit(c)) {
		x = (x << 1) + (x << 3) + (c ^ 48);
		c = getchar();
	}
	return f ? -x : x;
}

ll gcd(ll a, ll b) {
	return b == 0 ? a : gcd(b, a%b);
}
int sqr(int x) { return x * x; }


/*ll ans;
ll exgcd(ll a, ll b, ll &x, ll &y) {
	if (!b) {
		x = 1; y = 0; return a;
	}
	ans = exgcd(b, a%b, x, y);
	ll t = x; x = y; y = t - a / b * y;
	return ans;
}
*/


struct node {
	int lmax, rmax;
	int sum;
	int add;
	int len;
}tree[maxn << 2];
int n, m;

void pushup(int rt) {
	tree[rt].lmax = (tree[rt << 1].len == tree[rt << 1].lmax) ? tree[rt << 1].len + tree[rt << 1 | 1].lmax : tree[rt << 1].lmax;
	tree[rt].rmax = (tree[rt << 1 | 1].len == tree[rt << 1 | 1].rmax) ? tree[rt << 1 | 1].len + tree[rt << 1].rmax : tree[rt << 1 | 1].rmax;
	tree[rt].sum = max(tree[rt << 1].rmax + tree[rt << 1 | 1].lmax, max(tree[rt << 1].sum, tree[rt << 1 | 1].sum));
}
void pushdown(int rt) {
	if (tree[rt].add) {
		tree[rt << 1].add = tree[rt << 1 | 1].add = tree[rt].add;
		tree[rt << 1].lmax = tree[rt << 1].sum = tree[rt << 1].rmax = (tree[rt].add == 1) ? tree[rt << 1].len : 0;
		tree[rt << 1 | 1].rmax = tree[rt << 1 | 1].lmax = tree[rt << 1 | 1].sum = (tree[rt].add == 1) ? tree[rt << 1 | 1].len : 0;
		tree[rt].add = 0;
	}
}

void build(int l, int r, int rt) {
	tree[rt].add = 0;
	tree[rt].len = tree[rt].sum = tree[rt].lmax = tree[rt].rmax = r - l + 1;
	if (l == r) {
		return;
	}
	int mid = (l + r) >> 1;
	build(l, mid, rt << 1); build(mid + 1, r, rt << 1 | 1);
	pushup(rt);
}

void upd(int L, int R, int l, int r, int rt, int tg) {
	if (L <= l && r <= R) {
		tree[rt].add = tg;
		tree[rt].sum = tree[rt].lmax = tree[rt].rmax = (tg == 1) ? tree[rt].len : 0;
		return;
	}
	pushdown(rt);
	int mid = (l + r) >> 1;
	if (L <= mid)upd(L, R, l, mid, rt << 1, tg);
	if (mid < R)upd(L, R, mid + 1, r, rt << 1 | 1, tg);
	pushup(rt);
}

int query(int l, int r, int rt, int len) {
	if (l == r)return l;
	pushdown(rt);
	int mid = (l + r) >> 1;
	if (tree[rt << 1].sum >= len)return query(l, mid, rt << 1, len);
	if (tree[rt << 1].rmax + tree[rt << 1 | 1].lmax >= len)return mid - tree[rt << 1].rmax + 1;
	return query(mid + 1, r, rt << 1 | 1, len);
}

int main() {
	//ios::sync_with_stdio(0);
	rdint(n); rdint(m);
	build(1, n, 1);
	while (m--) {
		int op; rdint(op);
		if (op == 1) {
			int x; rdint(x);
			if (tree[1].sum >= x) {
				int ans = query(1, n, 1, x);
				cout << ans << endl;
				upd(ans, ans + x - 1, 1, n, 1, 2);
			}
			else cout << 0 << endl;
		}
		else {
			int x, y; rdint(x); rdint(y);
			upd(x, x + y - 1, 1, n, 1, 1);
		}
	}
	return 0;
}
 
  

猜你喜欢

转载自www.cnblogs.com/zxyqzy/p/10293257.html
今日推荐