算法设计课第七周作业

7. Funny Game

Description

Two players, Singa and Suny, play, starting with two natural numbers. Singa, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Suny, the second player, does the same with the two resulting numbers, then Singa, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):

         25 7
 
         11 7
 
          4 7
 
          4 3
 
          1 3
 
          1 0

an Singa wins.

Input

The input consists of a number of lines. Each line contains two positive integers (<2^31) giving the starting two numbers of the game. Singa always starts first. The input ends with two zeros.

Output

For each line of input, output one line saying either Singa wins or Suny wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input

28 15
15 24
0 0

Sample Output

Singa wins
Suny wins

解题思路

情况1:如果其中一个数不比另外一个数大一倍或一倍以上时,游戏将进行简单地相减。
情况2:如果,出现一个数是另外一个数的n倍,游戏结束。
情况3::当其中一个数是另外一个数的二倍以上(n倍)时,这时玩家可以根据逆推的方法选择减去n倍或者n-1倍,以达到让自己赢的情况。

代码

#include<iostream>

using namespace std;

int main()
{
    int num1, num2;
    cin >> num1 >> num2;

    while(num1 || num2)
    {
        int nultipleNum1, nultipleNum2;
        nultipleNum1 = num1;
        nultipleNum2 = num2;
        int result = 0;    //记录轮到谁,1:Singa,0:Suny

        while(nultipleNum1 && nultipleNum2) //如果两个数都大于0,游戏继续
        {
            result++;
            result %= 2;
            if(nultipleNum1 > nultipleNum2)
            {
                if(nultipleNum1 / nultipleNum2 >= 2) break;     //当遇到一个数是另外一个数的两倍或两倍以上时,即能赢得游戏
                else nultipleNum1 -= nultipleNum2;
            }else
            {
                if(nultipleNum2 / nultipleNum1 >= 2) break;
                else nultipleNum2 -= nultipleNum1;
            }
        }

        if(result == 1) cout << "Singa wins" << endl;
        else cout << "Suny wins" << endl;

        cin >> num1 >> num2;
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_38873581/article/details/86518333