PAT-A 1092 To Buy or Not to Buy (20 分)/ PAT-B 1039到底买不买(20分)

1092 To Buy or Not to Buy (20 分)

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.

For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

figbuy.jpg

Figure 1

Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:

For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:

ppRYYGrrYBR2258
YrR8RrY

Sample Output 1:

Yes 8

Sample Input 2:

ppRYYGrrYB225
YrR8RrY

Sample Output 2:

No 2
#include <bits/stdc++.h>//包含C++所有头文件

using namespace std;

int main()
{
    char shop[1010];
    char eva[1010];
    map<char, int> has;//颜色->数量,商店有的
    map<char, int> need;//颜色->数量,Eva需要的
    int extra = 0;
    int shortage = 0;
    scanf("%s%s", shop, eva);
    for(int i = 0; i < strlen(shop); i++)
    {   //统计商店有的珠子的颜色及其数量
        if(has.find(shop[i]) == has.end())
            has[shop[i]] = 1;
        else
            has[shop[i]]++;
    }
    for(int i = 0; i < strlen(eva); i++)
    {   //统计EVA需要的颜色及其数量
        if(need.find(eva[i]) == need.end())
            need[eva[i]] = 1;
        else
            need[eva[i]]++;
    }
    for(auto it = need.begin(); it != need.end(); it++)
    {   //对比商店有的和Eva需要的
        if(has.find(it->first) == has.end())//商店没有该颜色
            shortage += it->second;
        else if(has.find(it->first)->second >= it->second)//商店有这种颜色,数量充足
            extra += has.find(it->first)->second - it->second;
        else //商店有,但是这种颜色数量不足
            shortage += it->second - has.find(it->first)->second;
    }
    if(shortage == 0)
    {
        for(auto it = has.begin(); it != has.end(); it++)
        {   //统计Eva不需要但是必须买的颜色
            if(need.find(it->first) == need.end())//该种颜色EVA不需要
                extra += it->second;
        }
        printf("Yes %d", extra);
    }
    else
        printf("No %d", shortage);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38127801/article/details/86515331
今日推荐