PAT 1042 Shuffling Machine python解法

1042 Shuffling Machine (20 分)
Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, …, S13,
H1, H2, …, H13,
C1, C2, …, C13,
D1, D2, …, D13,
J1, J2
where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:
2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
Sample Output:
S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

题意是让我们把54张扑克牌按照给定的顺序洗牌,对于[S3, H5, C1, D13 ,J2]这5张牌, 给定洗牌顺序{4, 2, 5, 3, 1},表示把第1张牌放到第4个位置,第二张放到第2个位置,第3张放到第5个位置,第4张放到第3个位置,第5张放到第1个位置,最终结果为J2, H5, D13, S3, C1。输入数据的第一行是洗牌的次数,第二行是给定的顺序。
解题思路:首先是用一个列表来保存54张牌(代码中给出了两种方式)。每次洗牌都是一样的步骤,可以写一个Shuffle函数来实现,参数是初始牌列表initial和洗牌顺序order,然后复制一份到一个临时列表temp中,用来保存中途的数据,循环取order的元素,把对应order下标的initial值放到临时列表temp中(注意列表的下标从0开始,给定的顺序从1开始),最后将temp拷贝到initial中返回。根据洗牌次数确定Shuffle函数的循环次数。

#第一种生成54张牌的方式
flower = ['S','H','C','D','J']
initial = []
for i in range(54):
    initial.append(flower[i//13]+str(i%13+1)) 
#print(initial)
#第二种生成54张牌的方式
#initial = [['S'+str(i) for i in range(1,14)],['H'+str(i) for i in range(1,14)],['C'+str(i) for i in range(1,14)],['D'+str(i) for i in range(1,14)],['J'+str(i) for i in range(1,3)]]
#initial = [a for c in initial for a in c]
#print(initial)

##initial = ['S1', 'S2', 'S3', 'S4', 'S5', 'S6', 'S7', 'S8', 'S9', 'S10', 'S11', 'S12', 'S13', 'H1', 'H2', 'H3', 'H4', 'H5', 'H6', 'H7', 'H8', 'H9', 'H10', 'H11', 'H12', 'H13', 'C1', 'C2', 'C3', 'C4', 'C5', 'C6', 'C7', 'C8', 'C9', 'C10', 'C11', 'C12', 'C13', 'D1', 'D2', 'D3', 'D4', 'D5', 'D6', 'D7', 'D8', 'D9', 'D10', 'D11', 'D12', 'D13', 'J1', 'J2']
times = int(input())
order = list(map(int,input().split()))
#order = [36, 52, 37, 38, 3, 39, 40, 53, 54, 41, 11, 12, 13, 42, 43, 44, 2, 4, 23, 24, 25, 26, 27, 6, 7, 8, 48, 49, 50, 51, 9, 10, 14, 15, 16, 5, 17, 18, 19, 1, 20, 21, 22, 28, 29, 30, 31, 32, 33, 34, 35, 45, 46, 47]
#order = [4, 2, 5, 3, 1]
#print(initial)
def Shuffle(initial,order):
    temp = initial.copy()   
    for i in range(len(order)):
        temp[order[i]-1] = initial[i]
    initial = temp.copy()
    return initial

for i in range(times):
    initial = Shuffle(initial,order)

print(' '.join(initial))

猜你喜欢

转载自blog.csdn.net/qq_36936510/article/details/86072615