HDU - 2099 数的尾巴

一个整数,只知道前几位,不知道末二位,被另一个整数除尽了,那么该数的末二位该是什么呢?

Input

输入数据有若干组,每组数据包含二个整数a,b(0<a<10000, 10<b<100),若遇到0 0则处理结束。

Output

对应每组数据,将满足条件的所有尾数在一行内输出,格式见样本输出。同组数据的输出,其每个尾数之间空一格,行末没有空格。

Sample Input

200 40
1992 95
0 0

Sample Output

00 40 80
15

解题思路:直接枚举所有的情况就行了,在输出格式注意下,行末没有空格,

AC代码:

#include<iostream>
using namespace std;
int main()
{
	int a,b;
	while(cin>>a>>b,a+b)
	{
		int ans,k=1;
		for(int i=0;i<10;i++)//十位 
		{
			for(int j=0;j<10;j++)//个位 
			{
				ans=a*100+i*10+j; 
				if(ans%b==0)
				{
					{
						if(k)
						{
							cout<<i<<j;
							k=0;
						}
						else
							cout<<' '<<i<<j;	
					}
				}
			}
		}
		cout<<endl;
	} 
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_40707370/article/details/85056035