HDU 2099 整除的尾数

http://acm.hdu.edu.cn/showproblem.php?pid=2099

Problem Description
一个整数,只知道前几位,不知道末二位,被另一个整数除尽了,那么该数的末二位该是什么呢?
 
Input
输入数据有若干组,每组数据包含二个整数a,b(0<a<10000, 10<b<100),若遇到0 0则处理结束。
 
Output
对应每组数据,将满足条件的所有尾数在一行内输出,格式见样本输出。同组数据的输出,其每个尾数之间空一格,行末没有空格。
 
Sample Input
200 40
1992 95
0 0
 
Sample Output
00 40 80
15
 
 
代码:
#include <bits/stdc++.h>

using namespace std;
//int x;
int a[20];

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m)&&n!=0&&m!=0)
    {
        int cnt=0;
        for(int i=0; i<=99; i++)
        {
            if((n*100+i)%m==0)
            {
                cnt++;
                a[cnt]=i;
            }
        }
        for(int i=1; i<=cnt; i++)
        {
            if(i!=cnt)
                printf("%02d ",a[i]);
            else
                printf("%02d\n",a[cnt]);
        }
    }
    return 0;
}

  

猜你喜欢

转载自www.cnblogs.com/zlrrrr/p/9248415.html