PAT TOP 1027 Larry and Inversions (35)

问题描述:

1027 Larry and Inversions (35 分)

Larry just studied the algorithm to count number of inversions. He's very interested in it. He's considering another problem: Given a permutation of integers from 1 to n, how many inversions it has if we reverse one of its subarray?

Formally speaking, given an integer array a (indices are from 0 to n−1) which contains a permutation of integers from 1 to n, two elements a[i] and a[j] form an inversion if a[i]>a[j] and i<j. Your job is to count, for each pair of 0≤i≤j<n, the number of inversions if we reverse the subarray from a[i] to a[j].

Input Specification:

Each input file contains one test case. Each case consists of a positive integer n (≤1,000) in the first line, and a permutation of integers from 1 to n in the second line. The numbers in a line are separated by a single space.

Output Specification:

For each test case, output n(n+1)/2 integers in a single line. The results are for reversing subarray indicating by all possible pairs of indices 0≤i≤j<n in i-major order -- that is, the first n results are for the reverse of subarrary [0..0], [0..1], ...[0..n−1]; the next n−1 results are for the reverse of subarry [1..1], [1..2],..., [1..n−1] and so on.

All the numbers in a line must be separated by a single space, with no extra space at the beginning or the end of the line.

Sample Input:

3
2 1 3

Sample Output:

1 0 2 1 2 1

Hint:

The original array is { 2, 1, 3 }.

  • Reversing subarray [0..0] makes { 2, 1, 3 } which has 1 inversion.
  • Reversing subarray [0..1] makes { 1, 2, 3 } which has 0 inversion.
  • Reversing subarray [0..2] makes { 3, 1, 2 } which has 2 inversions.
  • Reversing subarray [1..1] makes { 2, 1, 3 } which has 1 inversion.
  • Reversing subarray [1..2] makes { 2, 3, 1 } which has 2 inversions.
  • Reversing subarrays [2..2] makes { 2, 1, 3 } which has 1 inversion.

时隔一年的pat top博主又回来啦。这一题是和逆序数相关的问题,掌握必要的数学知识很重要。

事实上,对于一个排列(a[1],a[2]..a[n]),若它的逆序数为S,则它的逆排列(a[n],a[n-1]..a[1])的逆序数为S'=n(n-1)/2-S。更进一步,对于它的一个逆序数为T的子排列(a[i],a[i+1]...a[j]),若将其逆序,使(a[1]...a[i],a[i+1]...a[j]...a[n]),成为(a[1]...a[j],a[j-1]...a[i]...a[n]),则(a[1]...a[j],a[j-1]...a[i]...a[n])的逆序数为S''=S-2T+(j-i+1)(j-i)/2,这两个结论读者自证。

顺便感谢一下大家对博主的支持。

AC代码:

#include<bits/stdc++.h>
using namespace std;
int n,k;
vector<int> v;
vector<int> vl;
int main()
{
//  freopen("data.txt","r",stdin);
  	scanf("%d",&n);
  	vl.resize(n*n,0);
  	for(int i=0;i<n;i++)
  	{
		scanf("%d",&k);
		v.emplace_back(k-1);
	}
	int brev=0;
	for(int i=0;i<n;++i)
	{
		int rev=0;
		for(int j=i;j<n;++j)
		{
			if(v[j]<v[i])
			rev++;
			vl[i*n+j]=rev;
		}
		brev+=rev;
	}
	bool flag=false;
	for(int i=0;i<n;i++)
	for(int j=i;j<n;j++)
	{
		if(i==j)
		{
			if(flag)
			printf(" ");
			else
			flag=true;
			printf("%d",brev);
		}
		else
		{
			int drev=0;
			for(int t=i;t<j;t++)
			drev+=vl[t*n+j];
			printf(" %d",brev-2*drev+(j-i)*(j-i+1)/2);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/baidu_37550206/article/details/85405574