B - Least Common Multiple

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
 

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1

Sample Output

105
10296

题意:给你n个数,求他们的最小公倍数

思路:首先有一个定理:两个数的乘积等于最大公因数与最小公倍数的乘积,所以我们可以先求最大公因数(gcd法)

          

#include<stdio.h>

int gcd(int n,int m)  
{
   int t,ans;
   int a = n,b = m;
   if(n < m)   //gcd要求分子要最大
   {
   	  t = n;
   	  n = m;
   	  m = t;
   }
   
   while(m)
   {
   	   ans = m;
   	   m = n%m;
   	   n = ans;
   }
   
   return a/n*b;  //防止两数乘积过大	
}

int main()
{
	int t,n,i,m;
	long long ans = 1; 
	scanf("%d",&t);
	while(t--)
	{
		
		scanf("%d",&n);
		ans = 1;
		for(i = 0;i < n;++i)
		{
			scanf("%d",&m);
			ans=gcd(ans,m);
		}
		printf("%lld\n",ans);
	}
}

猜你喜欢

转载自blog.csdn.net/qq_40511966/article/details/84196523