1127. ZigZagging on a Tree (30)【已知中序与后序求层序遍历】

版权声明:噗噗个噗~~~ https://blog.csdn.net/Puyar_/article/details/79591985

1127. ZigZagging on a Tree (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15
题解
#include <bits/stdc++.h>
#include<vector>
#define ms(x,y) memset(x,y,sizeof(x))
const int M=1e3+10;
using namespace std;
int j,k,n,m,q;
int root;
vector<int>post,in,res[M];
int tree[M][2];
int depth;
struct node
{
    int index;
    int depth;
};

void dfs(int &index,int pl,int pr,int inl,int inr)
{
   if(inl>inr)return;
   index=pr;
   int i=0;
   while(in[i]!=post[pr])i++;
   dfs(tree[index][0],pl,pl+i-inl-1,inl,i-1);
   dfs(tree[index][1],pl+i-inl,pr-1,i+1,inr);
}
void bfs()
{
    queue<node>q;
    q.push(node{root,0});
    while(!q.empty()){
        node t=q.front();
        q.pop();int kk=t.index;
        res[t.depth].push_back(post[kk]);
        if(tree[kk][0]!=0)
            q.push(node{tree[kk][0],t.depth+1});
        if(tree[kk][1]!=0)
            q.push(node{tree[kk][1],t.depth+1});
    }
}

int main()
{
    scanf("%d",&n);
    post.resize(n+1);in.resize(n+1);
    for(int i=1;i<=n;i++)scanf("%d",&in[i]);
    for(int i=1;i<=n;i++)scanf("%d",&post[i]);
    dfs(root,1,n,1,n);
    bfs();
    printf("%d",res[0][0]);
    for(int i=1;i<35;i++){
        if(i%2==1)
            for(int j=0;j<res[i].size();j++)printf(" %d",res[i][j]);
        else {
            for(int j=res[i].size()-1;j>=0;j--)printf(" %d",res[i][j]);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Puyar_/article/details/79591985
今日推荐