1127 ZigZagging on a Tree(30 分)(C++)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

考点:树的遍历之后序中序转层次;

其实什么之字形都是花架子,能得到层次遍历一切就迎刃而解,只是存储和输出层次遍历的时候动动手脚就好啦

#include <iostream>
#include <vector>
using namespace std;
int n,post[40],in[40];
std::vector<int> level[40];
void dfs(int poststart,int postend,int instart,int inend,int index){
    if(poststart>postend)
        return;
    int i=instart;
    while(i<=inend&&in[i]!=post[postend])
        i++;
    dfs(poststart,poststart+(i-instart)-1,instart,i-1,index+1);
    level[index].push_back(in[i]);
    dfs(poststart+(i-instart),postend-1,i+1,inend,index+1);
}
int main(){
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%d",&in[i]);
    for(int i=0;i<n;i++)
        scanf("%d",&post[i]);
    dfs(0,n-1,0,n-1,1);
    printf("%d",post[n-1]);
    for(int i=2;i<35;i++){
        if(i%2==0)
            for(int j=0;j<level[i].size();j++)
                printf(" %d",level[i][j]);
        else
            for(int j=level[i].size()-1;j>=0;j--)
                printf(" %d",level[i][j]);
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41562704/article/details/82501093