AtCoder Beginner Contest 095 C题

C - Half and Half


Time limit : 2sec / Memory limit : 256MB

Score : 300 points

Problem Statement

"Pizza At", a fast food chain, offers three kinds of pizza: "A-pizza", "B-pizza" and "AB-pizza". A-pizza and B-pizza are completely different pizzas, and AB-pizza is one half of A-pizza and one half of B-pizza combined together. The prices of one A-pizza, B-pizza and AB-pizza are A yen, B yen and C yen (yen is the currency of Japan), respectively.

Nakahashi needs to prepare X A-pizzas and Y B-pizzas for a party tonight. He can only obtain these pizzas by directly buying A-pizzas and B-pizzas, or buying two AB-pizzas and then rearrange them into one A-pizza and one B-pizza. At least how much money does he need for this? It is fine to have more pizzas than necessary by rearranging pizzas.

Constraints

  • 1A,B,C5000
  • 1X,Y105
  • All values in input are integers.

Input

Input is given from Standard Input in the following format:

A B C X Y

Output

Print the minimum amount of money required to prepare X A-pizzas and Y B-pizzas.


Sample Input 1

Copy
1500 2000 1600 3 2

Sample Output 1

Copy
7900

It is optimal to buy four AB-pizzas and rearrange them into two A-pizzas and two B-pizzas, then buy additional one A-pizza.


Sample Input 2

Copy
1500 2000 1900 3 2

Sample Output 2

Copy
8500

It is optimal to directly buy three A-pizzas and two B-pizzas.


Sample Input 3

Copy
1500 2000 500 90000 100000

Sample Output 3

Copy
100000000

It is optimal to buy 200000 AB-pizzas and rearrange them into 100000 A-pizzas and 100000 B-pizzas. We will have 10000 more A-pizzas than necessary, but that is fine.

读完题就感觉应该是挺好做的,就最后一个样例应该是本题的坑所在。

用了点dp的方法。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
//C题
using namespace std;
int dp[100010];
int main()
{
    int A,B,C,X,Y,n,m,ans;int flag=0;
    scanf("%d %d %d %d %d",&A,&B,&C,&X,&Y);
    if(X>Y){
        n=Y;flag=1;
        m=X;
    }
    if(X<Y){
        n=X;flag=2;
        m=Y;
    }
    if(X==Y){
        n=X;
    }
    for(int i=1;i<=n;i++){
        dp[i]=min(dp[i-1]+A+B,dp[i-1]+2*C);
    }//如果是两种批萨需求不一样那么就先求出相同的那部分的最小钱数
    if(flag!=0){//对于多出的那部分分开进行比较,看哪种策略钱数更少
            if(flag==1){
        for(int j=n+1;j<=m;j++){
            dp[j]=min(dp[j-1]+A,dp[j-1]+2*C);
        }
        ans=dp[m];
     }
     if(flag==2){
        for(int j=n+1;j<=m;j++){
            dp[j]=min(dp[j-1]+B,dp[j-1]+2*C);
        }
        ans=dp[m];
     }
    }
    else ans=dp[n];
    printf("%d\n",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sinat_40948489/article/details/80047680