【笨方法学PAT】【未完成】1029 Median (25 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/84631625

一、题目

Given a set of N (>1) positive integers, you are supposed to partition them into two disjoint sets A​1​​ and A​2​​ of n​1​​ and n​2​​numbers, respectively. Let S​1​​ and S​2​​ denote the sums of all the numbers in A​1​​ and A​2​​, respectively. You are supposed to make the partition so that ∣n​1​​−n​2​​∣ is minimized first, and then ∣S​1​​−S​2​​∣ is maximized.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤10​5​​), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 2​31​​.

Output Specification:

For each case, print in a line two numbers: ∣n​1​​−n​2​​∣ and ∣S​1​​−S​2​​∣, separated by exactly one space.

Sample Input 1:

10
23 8 10 99 46 2333 46 1 666 555

Sample Output 1:

0 3611

Sample Input 2:

13
110 79 218 69 3721 100 29 135 2 6 13 5188 85

Sample Output 2:

1 9359

二、题目大意

排序求和。

三、考点

vector

四、注意

1、先分组,后求和。

五、代码(内存超限)

#include<iostream>
#include<vector>
using namespace std;
int main() {
	//read
	long int n1, n2, n;
	vector<long int> v1, v2, v;
	v.push_back(0);
	cin >> n1;
	v1.resize(n1 + 1);
	for (int i = 1; i <= n1; ++i)
		cin >> v1[i];

	cin >> n2;
	n = n1 + n2;
	if (n % 2 == 0)
		n = n / 2;
	else
		n = n / 2 + 1;
	int j = 1;
	for (int i = 1; i <= n2; ++i) {
		long int a;
		cin >> a;
		while (j<=n1&&a > v1[j]) {
			v.push_back(v1[j]);
			j++;
			if (v.size() > n+1 ) {
				cout << v[n];
				system("pause");
				return 0;
			}
		}
		v.push_back(a);
		if (v.size() > n + 1) {
			cout << v[n];
			system("pause");
			return 0;
		}
	}

	system("pause");
	return 0;
}

六、代码

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/84631625