【笨方法学PAT】1103 Integer Factorization (30 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/84870977

一、题目

The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n[1]^P + ... n[K]^P

where n[i] (i = 1, ..., K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 12​2​​+4​2​​+2​2​​+2​2​​+1​2​​, or 11​2​​+6​2​​+2​2​​+2​2​​+2​2​​, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a​1​​,a​2​​,⋯,a​K​​ } is said to be larger than { b​1​​,b​2​​,⋯,b​K​​ } if there exists 1≤L≤K such that a​i​​=b​i​​ for i<L and a​L​​>b​L​​.

If there is no solution, simple output Impossible.

Sample Input 1:

169 5 2

Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

Sample Input 2:

169 167 3

Sample Output 2:

Impossible

二、题目大意

因式分解。

三、考点

DFS

四、注意

1、这个的dfs循环比较特殊,注意使用while和剪枝;

2、参考:https://www.liuchuo.net/archives/2451

五、代码

#include<iostream>
#include<vector>
#include<algorithm>
#include<math.h>
using namespace std;
int n, k, p, max_fac_sum=-1;
vector<int> vec_out_path, vec_path, v;

void init() {
	int tmp = 0, index = 1;
	while (tmp <= n) {
		v.push_back(tmp);
		tmp = pow(index, p);
		index++;
	}
}

void dfs(int root, int sum, int k_num, int fac_sum) {
	//sum
	if (k_num == k) {
		if (sum == n && fac_sum > max_fac_sum) {
			max_fac_sum = fac_sum;
			vec_out_path = vec_path;
		}
		return;
	}

	//next dfs
	while (root >= 1) {
		if (sum + v[root] <= n) {
			vec_path.push_back(root);
			dfs(root, sum + v[root], k_num + 1, fac_sum + root);
			vec_path.pop_back();
		}
		root--;
	}

	return;
}

int main() {
	//read
	cin >> n >> k >> p;

	//init
	init();

	//dfs
	dfs(v.size() - 1, 0, 0, 0);

	//output
	if (max_fac_sum == -1)
		cout << "Impossible" << endl;
	else {
		printf("%d = ", n);
		for (int i = 0; i < vec_out_path.size(); ++i) {
			if (i != 0)
				cout << " + ";
			cout << vec_out_path[i] << "^" << p;
		}
		cout << endl;
	}

	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/84870977