【PAT】A1103. Integer Factorization (30)

Description:
The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n1^P + … nK^P

where ni (i=1, … K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112 + 62 + 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen — sequence { a1, a2, … aK } is said to be larger than { b1, b2, … bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL

If there is no solution, simple output “Impossible”.

扫描二维码关注公众号,回复: 2873898 查看本文章

Sample Input 1:
169 5 2


Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2


Sample Input 2:
169 167 3


Sample Output 2:
Impossible

#pragma warning(disable:4996)
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <vector>
using namespace std;
vector<int> vfac, vre, vt;
int n, k, p, maxsum = -1;
void DFS(int index, int nowk, int sum, int facsum){
	if (sum == n&&nowk == k){
		if (facsum > maxsum){
			vre = vt;
			maxsum = facsum;
		}
		return;
	}
	if (sum > n || nowk > k)	return;
	if (index - 1 >= 0){
		vt.push_back(index);
		DFS(index, nowk + 1, sum + vfac[index], facsum + index);
		vt.pop_back();
		DFS(index - 1, nowk, sum, facsum);
	}
}
int main(){
	scanf("%d %d %d", &n, &k, &p);
	for (int i = 0; pow(i*1.0, p) <= n; i++)	vfac.push_back(pow(i*1.0, p));
	DFS(vfac.size() - 1, 0, 0, 0);
	if (maxsum != -1){
		printf("%d =", n);
		for (int i = 0; i < vre.size(); i++){
			if (!i)	printf(" %d^%d", vre[i], p);
			else	printf(" + %d^%d", vre[i], p);
		}
	}
	else	printf("Impossible");
	printf("\n");
	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/81366856