ACM 第八题

A + B Problem Too
Time limit 1000 ms
Memory limit 32768 kB
OS Windows

This problem is also a A + B problem,but it has a little difference,you should determine does (a+b) could be divided with 86.For example ,if (A+B)=98,you should output no for result.

Input
Each line will contain two integers A and B. Process to end of file.

Output
For each case, if(A+B)%86=0,output yes in one line,else output no in one line.

Sample Input
1 1
8600 8600

Sample Output
no
yes

问题链接:https://vjudge.net/problem/HDU-2101
问题简述:计算A+B能否被86整除。
问题分析:用if else语句分析A+B能否被86整除。

AC通过的C语言程序如下:

#include<iostream>
using namespace std;
int main()
{
	int a, b;
	while (cin >> a >> b)
	{
		if ((a + b) % 86 == 0)
			cout << "yes" << endl;
		else if ((a + b) % 86 != 0)
			cout << "no" << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43973938/article/details/84874330