不分大小写的Strstr

版权声明:个人做题总结专用~ https://blog.csdn.net/tb_youth/article/details/84888916

1614: Problem 3
Time Limit: 1 Sec Memory Limit: 128 MB
[Submit][Status][Web Board]
Description

fjxmlhx hates marshtomp, so he wants to ignore the “marshtomp” in every sentences. In order to making the sentence complete, he changes the word “marshtomp” into “fjxmlhx”

please create a class, then you must solve the problem via calling the method of the class with the object of the class.

Input

the input contains several lines

each line there exists a string whose length is no more than 200

Attention: the end of line has nothing to do with the beginning of the next line

Output

print the answer of the problem

Sample Input

marshTomp is beaten by fjxmlhx!
AmarshtompB

扫描二维码关注公众号,回复: 4462925 查看本文章

Sample Output

fjxmlhx is beaten by fjxmlhx!
AfjxmlhxB

HINT

Source
/*
对于C语言有分大小写的子串查找函数strstr,对于这题用strstr解决不了,因为它的子串匹配根据样例输出可以看出是不分大小写的,所以我就(借助不分大小写的比较函数strncasecmp和指针)自己写了个不分大小写的子串匹配函数,我叫它Strstr。
*/
AC_code:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
char *Strstr(char *a,const char *b)
{
    int len_b = strlen(b);
    while(*a)
    {
        if(strncasecmp(a,b,len_b)==0)
        {
            return a;
        }
        a++;
    }
    return NULL;
}
int main()
{
    char a[205];
    while(gets(a))
    {
        int len = strlen(a);
        char *p = a;
        const char *q ="marshTomp",*f = "fjxmlhx";
        while(Strstr(p,q))
        {
            char *start = Strstr(p,q);
            *start = '\0';
            *(start+1) = '\0';
            strncpy(start+2,f,7);
            p++;
        }
        for(int i = 0; i < len; i++)
        {
            if(a[i]!='\0')
                printf("%c",a[i]);
        }
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/tb_youth/article/details/84888916
今日推荐