hdoj 1408

盐水的故事

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24542 Accepted Submission(s): 6114

Problem Description
挂盐水的时候,如果滴起来有规律,先是滴一滴,停一下;然后滴二滴,停一下;再滴三滴,停一下…,现在有一个问题:这瓶盐水一共有VUL毫升,每一滴是D毫升,每一滴的速度是一秒(假设最后一滴不到D毫升,则花费的时间也算一秒),停一下的时间也是一秒这瓶水什么时候能挂完呢?

Input
输入数据包含多个测试实例,每个实例占一行,由VUL和D组成,其中 0<D<VUL<5000。

Output
对于每组测试数据,请输出挂完盐水需要的时间,每个实例的输出占一行。

Sample Input
10 1

Sample Output
13

蜜汁思路:水题,直接看代码

#include<cstdio>
using namespace std;
int main() {
    double n;
    double d;
    while(scanf("%lf%lf",&n,&d)!=EOF) {
        int m=n/d;
        if(n/d!=m)
            m++;
        int i=1;
        int sum=0;
        while(1) {
            sum+=i;
            if(sum>=m)
                break;
            i++;
        }
        if(sum-m==i)
            m=m+i-2;
        else
            m=m+i-1;
        printf("%d\n",m);
    }
}

猜你喜欢

转载自blog.csdn.net/D_mengxin/article/details/84949390