SDNUOJ 1059

Description
Uniform Resource Identifiers (or URIs) are strings like http://icpc.baylor.edu/icpc/, mailto:[email protected], ftp://127.0.0.1/pub/linux, or even just readme.txt that are used to identify a resource, usually on the Internet or a local computer. Certain characters are reserved within URIs, and if a reserved character is part of an identifier then it must be percent-encoded by replacing it with a percent sign followed by two hexadecimal digits representing the ASCII code of the character. A table of seven reserved characters and their encodings is shown below. Your job is to write a program that can percent-encode a string of characters.

Character Encoding
" " (space) %20
“!” (exclamation point) %21
“$” (dollar sign) %24
“%” (percent sign) %25
“(” (left parenthesis) %28
“)” (right parenthesis) %29
“*” (asterisk) %2a
Input
The input consists of one or more strings, each 1–1000 characters long and on a line by itself, followed by a line containing only “#” that signals the end of the input.A string may contain spaces, but not at the beginning or end of the string, and there will never be two or more consecutive spaces.
Output
For each input string, replace every occurrence of a reserved character in the table above by its percent-encoding, exactly as shown, and output the resulting string on a line by itself. Note that the percent-encoding for an asterisk is %2a (with a lowercase “a”) rather than %2A (with an uppercase “A”).
Sample Input
Happy Joy Joy!
http://icpc.baylor.edu/icpc/
plain_vanilla
(**)
?
the 7% solution

Sample Output
Happy%20Joy%20Joy%21
http://icpc.baylor.edu/icpc/
plain_vanilla
%28%2a%2a%29
?
the%207%25%20solution

#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;

int main()
{
    char s[1005];
    while(gets(s))
    {
        if(s[0] == '#')
            break;
        int len = strlen(s);
        for(int i = 0; i < len; i++) /// i < len不能等于,因为i从零开始(是s的第一个字符) 
        {
            switch(s[i])
            {
            case ' ':
                cout << "%20";
                break;
            case '!':
                cout << "%21";
                break;
            case '$':
                cout << "%24";
                break;
            case '%':
                cout << "%25";
                break;
            case '(':
                cout << "%28";
                break;
            case ')':
                cout << "%29";
                break;
            case '*':
                cout << "%2a";
                break;
            default:
                cout << s[i];
            }
        }
        cout << '\n';
        memset(s, 0, sizeof(s));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zhaobaole2018/article/details/84918723